summaryrefslogtreecommitdiff
path: root/net-misc/chrony/chrony-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 23:57:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 23:57:59 +0000
commitd39fec05a2fac9978cd77634744637509744b561 (patch)
treed6c800b18c7b6a3c88e80b284f5c91a060e1ecc7 /net-misc/chrony/chrony-9999.ebuild
parent220240f060e150ba4c4bb2d0f2a07f7c8f9de480 (diff)
gentoo auto-resync : 18:01:2023 - 23:57:58
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index e89af76426c6..64fe1397809a 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,7 +27,7 @@ S="${WORKDIR}/${P/_/-}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+caps +cmdmon debug html ipv6 libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
+IUSE="+caps +cmdmon debug html libtomcrypt +nettle nss +ntp +nts +phc pps +readline +refclock +rtc samba +seccomp +sechash selinux"
# nettle > nss > libtomcrypt in configure
REQUIRED_USE="
sechash? ( || ( nettle nss libtomcrypt ) )
@@ -78,6 +78,7 @@ fi
PATCHES=(
"${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
"${FILESDIR}"/${PN}-4.2-systemd-gentoo.patch
+ "${FILESDIR}"/${P}-strict-prototypes-clang16.patch
)
src_prepare() {
@@ -116,7 +117,6 @@ src_configure() {
$(usev !caps '--disable-linuxcaps')
$(usev !cmdmon '--disable-cmdmon')
$(usev debug '--enable-debug')
- $(usev !ipv6 '--disable-ipv6')
# USE=readline here means "readline-like functionality"
# chrony only supports libedit in terms of the library providing
@@ -163,6 +163,9 @@ src_compile() {
src_install() {
default
+ # Compatibility with other distributions who install to /etc/chrony.conf (bug #835461)
+ dosym -r /etc/chrony/chrony.conf /etc/chrony.conf
+
newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
newconfd "${T}"/chronyd.conf chronyd