summaryrefslogtreecommitdiff
path: root/net-misc/clockspeed/clockspeed-0.62-r8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /net-misc/clockspeed/clockspeed-0.62-r8.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'net-misc/clockspeed/clockspeed-0.62-r8.ebuild')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62-r8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62-r8.ebuild b/net-misc/clockspeed/clockspeed-0.62-r8.ebuild
new file mode 100644
index 000000000000..29bf5a916bca
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62-r8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Simple Network Time Protocol (NTP) client"
+HOMEPAGE="https://cr.yp.to/clockspeed.html"
+
+# this is the trailing part of the name for the latest leapseconds file.
+LEAPSECONDS_DATE="20081114"
+
+SRC_URI="https://cr.yp.to/clockspeed/${P}.tar.gz
+ https://dev.gentoo.org/~pacho/maintainer-needed/leapsecs.dat."$LEAPSECONDS_DATE""
+
+# http://cr.yp.to/distributors.html
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~mips x86"
+IUSE="static selinux"
+RESTRICT="mirror bindist test"
+
+DEPEND="sys-apps/groff"
+RDEPEND="net-dns/djbdns"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${ASFLAGS}" > conf-cc || die
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd
+ dosbin "${FILESDIR}"/ntpclockset
+
+ doman *.1
+ dodoc BLURB CHANGES INSTALL README THANKS TODO
+
+ insinto /var/lib/clockspeed
+ newins "${DISTDIR}"/leapsecs.dat."$LEAPSECONDS_DATE" leapsecs.dat
+}