summaryrefslogtreecommitdiff
path: root/net-misc/clockspeed/clockspeed-0.62-r9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 17:48:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 17:48:32 +0000
commit22230e510e031a97cafc85353610e573b7508e98 (patch)
tree5c9d831e9e8f88f2242dc85d277019715f77c501 /net-misc/clockspeed/clockspeed-0.62-r9.ebuild
parent1e39e6a8c127767a57f0465ed9ece4fefb44b4ae (diff)
gentoo auto-resync : 01:02:2024 - 17:48:32
Diffstat (limited to 'net-misc/clockspeed/clockspeed-0.62-r9.ebuild')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62-r9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62-r9.ebuild b/net-misc/clockspeed/clockspeed-0.62-r9.ebuild
new file mode 100644
index 000000000000..5607768def91
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62-r9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Simple Network Time Protocol (NTP) client"
+HOMEPAGE="https://cr.yp.to/clockspeed.html"
+
+# this is the trailing part of the name for the latest leapseconds file.
+LEAPSECONDS_DATE="20081114"
+
+SRC_URI="https://cr.yp.to/clockspeed/${P}.tar.gz
+ https://dev.gentoo.org/~pacho/maintainer-needed/leapsecs.dat."$LEAPSECONDS_DATE""
+
+# http://cr.yp.to/distributors.html
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="static selinux"
+RESTRICT="mirror bindist test"
+
+DEPEND="sys-apps/groff"
+RDEPEND="net-dns/djbdns"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fix-clang16-build.patch
+)
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${ASFLAGS}" > conf-cc || die
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd
+ dosbin "${FILESDIR}"/ntpclockset
+
+ doman *.1
+ dodoc BLURB CHANGES INSTALL README THANKS TODO
+
+ insinto /var/lib/clockspeed
+ newins "${DISTDIR}"/leapsecs.dat."$LEAPSECONDS_DATE" leapsecs.dat
+}