summaryrefslogtreecommitdiff
path: root/net-misc/dcetest/dcetest-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /net-misc/dcetest/dcetest-2.0.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'net-misc/dcetest/dcetest-2.0.ebuild')
-rw-r--r--net-misc/dcetest/dcetest-2.0.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/net-misc/dcetest/dcetest-2.0.ebuild b/net-misc/dcetest/dcetest-2.0.ebuild
index b88a73a876f2..b0b822c166a4 100644
--- a/net-misc/dcetest/dcetest-2.0.ebuild
+++ b/net-misc/dcetest/dcetest-2.0.ebuild
@@ -1,32 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="dcetest is a clone of the Windows rpcinfo"
HOMEPAGE="http://www.atstake.com/research/tools/info_gathering/"
-SRC_URI="http://www.atstake.com/research/tools/info_gathering/dcetest.tar"
+SRC_URI="mirror://gentoo/${PN}.tar -> ${P}.tar"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE=""
-DEPEND="sys-apps/sed"
-RDEPEND=""
-S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # cleanup the makefile a little
- sed -e '/^CC/d' -i Makefile
- sed -e 's/CFLAGS.*/CFLAGS += -Wall -funsigned-char -fPIC/g' -i Makefile
-}
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-2.0-fix-build-system.patch )
-src_compile() {
- emake || die
+src_configure() {
+ tc-export CC
+ append-cflags -funsigned-char -Wall
}
src_install() {
- dobin dcetest || die
+ dobin dcetest
dodoc CHANGELOG README VERSION nt4sp6adefault.txt out out.txt out2.txt w2ksp0.txt
}