summaryrefslogtreecommitdiff
path: root/net-misc/dhcpcd/dhcpcd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
commit37cf2a8dbadd546a550aac7c8079c3f77427cb63 (patch)
tree01b4d88cf5ffbb0cc059bd4e1cbca9d8352ee900 /net-misc/dhcpcd/dhcpcd-9999.ebuild
parent7bb99171a372e6cff495daf7dbef2e03d216be29 (diff)
gentoo auto-resync : 13:04:2023 - 05:42:42
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-9999.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index 6ad423e41da9..0c988adf5f2c 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd toolchain-funcs
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/NetworkConfiguration/dhcpcd.git"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
MY_P="${MY_P/_rc/-rc}"
- SRC_URI="https://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+ SRC_URI="https://github.com/NetworkConfiguration/dhcpcd/archive/refs/tags/${MY_P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_P}"
+
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="https://github.com/NetworkConfiguration/dhcpcd/
-https://roy.marples.name/projects/dhcpcd/"
+HOMEPAGE="https://github.com/NetworkConfiguration/dhcpcd/ https://roy.marples.name/projects/dhcpcd/"
+
LICENSE="BSD-2"
SLOT="0"
IUSE="debug +embedded ipv6 privsep +udev"
-COMMON_DEPEND="udev? ( virtual/udev )"
-DEPEND="${COMMON_DEPEND}"
+DEPEND="udev? ( virtual/udev )"
RDEPEND="
- ${COMMON_DEPEND}
+ ${DEPEND}
privsep? (
acct-group/dhcpcd
acct-user/dhcpcd