summaryrefslogtreecommitdiff
path: root/net-misc/dhcpcd/dhcpcd-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /net-misc/dhcpcd/dhcpcd-9999.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-9999.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild87
1 files changed, 43 insertions, 44 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index a146481fe88b..48ba26275d0c 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit systemd toolchain-funcs
+
if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://roy.marples.name/git/dhcpcd.git"
inherit git-r3
+ EGIT_REPO_URI="https://roy.marples.name/git/dhcpcd.git"
else
MY_P="${P/_alpha/-alpha}"
MY_P="${MY_P/_beta/-beta}"
@@ -15,8 +17,6 @@ else
S="${WORKDIR}/${MY_P}"
fi
-inherit eutils systemd toolchain-funcs
-
DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
HOMEPAGE="https://roy.marples.name/projects/dhcpcd"
LICENSE="BSD-2"
@@ -27,90 +27,89 @@ COMMON_DEPEND="udev? ( virtual/udev )"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
-src_configure()
-{
- local dev hooks rundir
+src_configure() {
+ local dev hooks=() rundir
use udev || dev="--without-dev --without-udev"
- hooks="--with-hook=ntp.conf"
- use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ hooks=( --with-hook=ntp.conf )
+ use elibc_glibc && hooks+=( --with-hook=yp.conf )
use kernel_linux && rundir="--rundir=${EPREFIX}/run"
- econf \
- --prefix="${EPREFIX}" \
- --libexecdir="${EPREFIX}/lib/dhcpcd" \
- --dbdir="${EPREFIX}/var/lib/dhcpcd" \
- --localstatedir="${EPREFIX}/var" \
- ${rundir} \
- $(use_enable embedded) \
- $(use_enable ipv6) \
- ${dev} \
- CC="$(tc-getCC)" \
- ${hooks}
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --libexecdir="${EPREFIX}/lib/dhcpcd"
+ --dbdir="${EPREFIX}/var/lib/dhcpcd"
+ --localstatedir="${EPREFIX}/var"
+ ${rundir}
+ $(use_enable embedded)
+ $(use_enable ipv6)
+ ${dev}
+ CC="$(tc-getCC)"
+ ${hooks[@]}
+ )
+ econf "${myeconfargs[@]}"
}
-src_install()
-{
+src_install() {
default
keepdir /var/lib/dhcpcd
newinitd "${FILESDIR}"/${PN}.initd ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
}
-pkg_postinst()
-{
- local dbdir="${EROOT%/}"/var/lib/dhcpcd old_files=
+pkg_postinst() {
+ local dbdir="${EROOT%/}"/var/lib/dhcpcd old_files=()
local old_old_duid="${EROOT%/}"/var/lib/dhcpcd/dhcpcd.duid
local old_duid="${EROOT%/}"/etc/dhcpcd.duid
local new_duid="${dbdir}"/duid
- if [ -e "${old_old_duid}" ]; then
+ if [[ -e "${old_old_duid}" ]] ; then
# Upgrade the duid file to the new format if needed
if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
fi
# Move the duid to /etc, a more sensible location
- if [ ! -e "${old_duid}" ]; then
+ if [[ ! -e "${old_duid}" ]] ; then
cp -p "${old_old_duid}" "${new_duid}"
fi
- old_files="${old_files} ${old_old_duid}"
+ old_files+=( "${old_old_duid}" )
fi
# dhcpcd-7 moves the files out of /etc
- if [ -e "${old_duid}" ]; then
- if [ ! -e "${new_duid}" ]; then
+ if [[ -e "${old_duid}" ]] ; then
+ if [[ ! -e "${new_duid}" ]] ; then
cp -p "${old_duid}" "${new_duid}"
fi
- old_files="${old_files} ${old_duid}"
+ old_files+=( "${old_duid}" )
fi
local old_secret="${EROOT%/}"/etc/dhcpcd.secret
local new_secret="${dbdir}"/secret
- if [ -e "${old_secret}" ]; then
- if [ ! -e "${new_secret}" ]; then
+ if [[ -e "${old_secret}" ]] ; then
+ if [[ ! -e "${new_secret}" ]] ; then
cp -p "${old_secret}" "${new_secret}"
fi
- old_files="${old_files} ${old_secret}"
+ old_files+=( "${old_secret}" )
fi
# dhcpcd-7 renames some files in /var/lib/dhcpcd
local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
local new_rdm="${dbdir}"/rdm_monotonic
- if [ -e "${old_rdm}" ]; then
- if [ ! -e "${new_rdm}" ]; then
+ if [[ -e "${old_rdm}" ]] ; then
+ if [[ ! -e "${new_rdm}" ]] ; then
cp -p "${old_rdm}" "${new_rdm}"
fi
- old_files="${old_files} ${old_rdm}"
+ old_files+=( "${old_rdm}" )
fi
local lease=
for lease in "${dbdir}"/dhcpcd-*.lease*; do
- [ -f "$lease" ] || continue
- old_files="${old_files} ${lease}"
- local new_lease=$(basename "$lease" | sed -e "s/dhcpcd-//")
- [ -e "${dbdir}/${new_lease}" ] && continue
+ [[ -f "${lease}" ]] || continue
+ old_files+=( "${lease}" )
+ local new_lease=$(basename "${lease}" | sed -e "s/dhcpcd-//")
+ [[ -e "${dbdir}/${new_lease}" ]] && continue
cp "${lease}" "${dbdir}/${new_lease}"
done
# Warn about removing stale files
- if [ -n "${old_files}" ]; then
+ if [[ -n "${old_files[@]}" ]] ; then
elog
elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
elog "${EROOT%/}/etc to ${dbdir}"
@@ -120,12 +119,12 @@ pkg_postinst()
elog "You should remove these files if you don't plan on reverting"
elog "to an older version:"
local old_file=
- for old_file in ${old_files}; do
+ for old_file in ${old_files[@]}; do
elog " ${old_file}"
done
fi
- if [ -z "$REPLACING_VERSIONS" ]; then
+ if [ -z "${REPLACING_VERSIONS}" ]; then
elog
elog "dhcpcd has zeroconf support active by default."
elog "This means it will always obtain an IP address even if no"