summaryrefslogtreecommitdiff
path: root/net-misc/electrum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
commit8796aaedb3257bbe4d80b0033408b2210b2259d6 (patch)
tree1ffee2ca4a87bd5dba43077259c000f9086fbfc8 /net-misc/electrum
parent61a1cada8ceb208845fa604b982216b0a7b099cb (diff)
gentoo auto-resync : 17:10:2024 - 04:04:26
Diffstat (limited to 'net-misc/electrum')
-rw-r--r--net-misc/electrum/Manifest2
-rw-r--r--net-misc/electrum/electrum-4.5.6.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index c839c52f275e..6c9b4709129d 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1,3 +1,5 @@
DIST electrum-4.5.5.gh.tar.gz 4927614 BLAKE2B 9b0bdf4f79ed15279bd8485b9d7fd1d911a5cdc6c3a2deb5e72dad7cd232c87d3f41f10ab572ab3969c9d1ddc65742d1983369a43946ab7f321d49975a50b41a SHA512 28121665cad7bc540600562d4d3e72e20108785c096647fdcc9eb8c26616a04730f53ba53b19f6a332eadc8e20a5524b33dab3719421aeb2b51a0531f9e8ef11
+DIST electrum-4.5.6.gh.tar.gz 5893660 BLAKE2B e1d79b64709995b2d8768afe4961a16e930502dcc79167dc1e4f8a53f3cb2573df466b3af4b4863bb4fea21cb2ce383a277f08e49d6b935fefaff0377070bf0f SHA512 b9a146ca6d4b29b215bb4bf6ad865856c3b8067d90c42fd740f3805aa37fc46f9072c2929401150b76423143ad63087da01b120bce591865d5f0f34cba941943
EBUILD electrum-4.5.5.ebuild 3035 BLAKE2B d1add81ec68d7d1b3ec1df1653bf9f6780afcd892638d3e4a050ff544c69bcdc0fa09a1828d35de593448eb2511a1cd1eee0d160dca6da9d42ad10c2b557bbf9 SHA512 7662eadc46eaeabe1acb07feba470dfc08f57e7a0cf95b8fedfd6c7b7dd0e99c8adc7d93a0f8508ac788a085c2166afcb62c272c3b53d021c8b30cd0f07d25de
+EBUILD electrum-4.5.6.ebuild 3037 BLAKE2B 4e3cad8a61cbb02623a406ef766032b54381b1995963a1b7c50dbfd7e894f6cdfe51d8576930f7c6bf70e438c88e4ddc7fe507618ed4173d44933fd18e035b71 SHA512 47ae0e4206b37e36cb5689608d5ebeabcd49c81edec82f1306e5d7affd8153d52ceb4bb4e8abf1a532a1b6ccd90a7ff9ca803677abec9c8aa384e5b51744db44
MISC metadata.xml 637 BLAKE2B ec4a0e57a1a11fa3a430c40b317e9a857b4128c7815fcd9fabe44adf85c47985325f4df3da9476b19f687026a145c7abf16a6a1ef6c8e25dd217732cdf77a076 SHA512 599ade68d31da44232ab7f520f0b9c054e7a26757aa7eed4f06350487d6c7c1dfc12bf2ba3dbddeb8ef8e8f0b67d093b91999cec422b3a5ea6dfadc9acf2fbc1
diff --git a/net-misc/electrum/electrum-4.5.6.ebuild b/net-misc/electrum/electrum-4.5.6.ebuild
new file mode 100644
index 000000000000..85c8d7cc1e8f
--- /dev/null
+++ b/net-misc/electrum/electrum-4.5.6.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="
+ https://electrum.org/
+ https://github.com/spesmilo/electrum/
+"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ <dev-libs/libsecp256k1-0.4
+ >=dev-python/aiohttp-socks-0.8.4[${PYTHON_USEDEP}]
+ =dev-python/aiorpcx-0.23*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # test for qml/PyQt6 GUI that doesn't work anyway
+ tests/test_qml_types.py
+)
+
+src_prepare() {
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ # make qdarkstyle dep optional
+ sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
+
+ # remove upper bounds from deps
+ sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ ver_test "${v}" -ge 4.3.4 && return
+ done
+
+ ewarn "If you are new to BitCoin, please be aware that:"
+ ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
+ ewarn " changes of value in the past."
+ ewarn "2. Cryptocurrency ownership is determined solely by the access to"
+ ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
+ ewarn " lost."
+ ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
+ ewarn " impact. BTC mining is consuming huge amounts of electricity."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}