summaryrefslogtreecommitdiff
path: root/net-misc/email-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
commit6243676c91946098c06d42bc87b5eb99aac40bf0 (patch)
treee6de308ba22148b4898b67b049c7f017ece8fea2 /net-misc/email-validator
parentb987a550f067c3da93b0664cf1fdc8a624c0aa38 (diff)
gentoo auto-resync : 25:04:2024 - 23:59:45
Diffstat (limited to 'net-misc/email-validator')
-rw-r--r--net-misc/email-validator/Manifest3
-rw-r--r--net-misc/email-validator/email-validator-1.1.0.ebuild37
-rw-r--r--net-misc/email-validator/metadata.xml19
3 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/email-validator/Manifest b/net-misc/email-validator/Manifest
new file mode 100644
index 000000000000..d13c329732a4
--- /dev/null
+++ b/net-misc/email-validator/Manifest
@@ -0,0 +1,3 @@
+DIST email-validator-1.1.0.tar.gz 17544 BLAKE2B a738c0828881fc65b4fd9a6ec0d660f39ed8337338afd8def452871149907f871b5938f03dd94bd7469be544eb3281dcd82f89fd6f80dcaaf9c5ee402194baa4 SHA512 c6714db0fbaf7aa03e5171347c4efe2485a367345a8a9d50f9143f73c18a0ab609aed62816868826d180370d5020f626fd8e31c08d4524cf5157227d0b200c31
+EBUILD email-validator-1.1.0.ebuild 934 BLAKE2B 6c1b8713ebdec2fa1ca534d788aeb87b722468a24697de5c0cf10fdd5c9c3b42a9ff13042b67bf90506470bdacb00434241f6e6b473999dd54ec2c97747f68f2 SHA512 1be41842d07d42ba9f579a04463f1efe6166e89bce29c4400387fea25fb89ad8144faec70a2ce6b4e4ff76e4baac22aa6d45a7bb84db495f948cffc8a3187a9b
+MISC metadata.xml 592 BLAKE2B dc3ab8adc61351a6991605b1be8fe913fe50dc679692e81d04f585b536fbf905c4b34cd5db1c3a5f278882f321b45578d3cd88af252d843c392cc7b249ae6148 SHA512 8c66f698edf0a957b08de2262764e767542bdf27ddde1b27902de562d70adfa74f9b24d0ae82d2116fe1709eb919739bb13abc99547de2da8abb22ce9cba2353
diff --git a/net-misc/email-validator/email-validator-1.1.0.ebuild b/net-misc/email-validator/email-validator-1.1.0.ebuild
new file mode 100644
index 000000000000..6157158555f4
--- /dev/null
+++ b/net-misc/email-validator/email-validator-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Basic syntax and deliverability checks on email addresses"
+HOMEPAGE="https://michael.orlitzky.com/code/email-validator.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT=test # Ambiguous module name ‘Network.DNS’: dns-4.0.1 resolv-0.1.2.0
+
+RDEPEND=">=dev-haskell/cmdargs-0.10:=
+ >=dev-haskell/dns-2:=
+ >=dev-haskell/email-validate-2:=
+ >=dev-haskell/hunit-1.2:=
+ >=dev-haskell/parallel-io-0.3:=
+ >=dev-haskell/pcre-light-0.4:=
+ >=dev-haskell/tasty-0.8:=
+ >=dev-haskell/tasty-hunit-0.8:=
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.9 )
+"
+
+src_install() {
+ haskell-cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}
diff --git a/net-misc/email-validator/metadata.xml b/net-misc/email-validator/metadata.xml
new file mode 100644
index 000000000000..ffea1c02a1d2
--- /dev/null
+++ b/net-misc/email-validator/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Validate an email address using three techniques:
+
+ * Ensuring that the length of local and domain parts is within the
+ RFC-specified limits.
+
+ * A syntax check using a regular expression, or the full RFC 5322
+ grammar.
+
+ * Confirmation of valid MX records (or, optionally, 'A'
+ records) for the domain.
+ </longdescription>
+</pkgmetadata>