summaryrefslogtreecommitdiff
path: root/net-misc/gallery-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-misc/gallery-dl
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest6
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild45
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.15.3.ebuild45
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild45
-rw-r--r--net-misc/gallery-dl/metadata.xml19
5 files changed, 160 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
new file mode 100644
index 000000000000..f97b743f9294
--- /dev/null
+++ b/net-misc/gallery-dl/Manifest
@@ -0,0 +1,6 @@
+DIST gallery-dl-1.15.2.tar.gz 323739 BLAKE2B 99a06331bd7dc6ec951749129ad0ac797d9ce2d9f98e75a29198fd47d0481c43b96922ea08149abfe990e8994a19b3170853618de9b51465264d100dba777f32 SHA512 7f31c0485d9de6eaf76e7b0772e66049f9aa8fd7d77d3ef6fd2803d7ec7dddbf3419051c9d8b3984eb86a8fbbf9a168cf8ec69a55082a38e2ca23cfc3574b1f4
+DIST gallery-dl-1.15.3.tar.gz 325926 BLAKE2B 9ae31ba89a60460cd041fe9f353d4a7d1dab14fe63a8967f1a94f8d0ea42ef30032e5f734cbb370f5ac681f9274ba756a156acc7bd11ca4b5aad387fdc6be76f SHA512 618dc26ba74274c961cce1ef058fce3e12741366329ce50d09421245987a88a796be3f1a31926e8b2c33cc87cddcde3585f74f4f1a80347153c2a7a9cab7e3c0
+EBUILD gallery-dl-1.15.2-r1.ebuild 1110 BLAKE2B b0bf6aa77a35b679c19734c0d2ef59c1402ad11772317efff72bcb3110a8d8e817e0df1ab59879156b9d7fe9252c7f940721915847ae2deeaf3e4eb1279652fc SHA512 ac13faf74cc15ec4456c84898ea379c3ee6a3b75a83a25c9483697f6dc7147bce66ed1ae303736a5682d3020fd27b9d165107655817bf054baae5132cc4b1bd7
+EBUILD gallery-dl-1.15.3.ebuild 1110 BLAKE2B b0bf6aa77a35b679c19734c0d2ef59c1402ad11772317efff72bcb3110a8d8e817e0df1ab59879156b9d7fe9252c7f940721915847ae2deeaf3e4eb1279652fc SHA512 ac13faf74cc15ec4456c84898ea379c3ee6a3b75a83a25c9483697f6dc7147bce66ed1ae303736a5682d3020fd27b9d165107655817bf054baae5132cc4b1bd7
+EBUILD gallery-dl-9999.ebuild 1110 BLAKE2B b0bf6aa77a35b679c19734c0d2ef59c1402ad11772317efff72bcb3110a8d8e817e0df1ab59879156b9d7fe9252c7f940721915847ae2deeaf3e4eb1279652fc SHA512 ac13faf74cc15ec4456c84898ea379c3ee6a3b75a83a25c9483697f6dc7147bce66ed1ae303736a5682d3020fd27b9d165107655817bf054baae5132cc4b1bd7
+MISC metadata.xml 767 BLAKE2B 513bfe624e86287f7ba2d8fbcfd2d6e1dd66a79c9a4325a03037ff11f95c4eeae320b47f7ea09b8e6fb6643a42263556a56e02eef7ca8405541b25cc8f710837 SHA512 d5aa8f0a5bbfc2231495aa2f3dd3f6b4fe0a491b3a1d527a304a41d8d1a7f35a60fabd7283a55ff14ed30be328f557d9e0c5dd884648030a8ad5010418f08d5d
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
new file mode 100644
index 000000000000..458d0edf5edc
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.15.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild
new file mode 100644
index 000000000000..458d0edf5edc
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.15.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
new file mode 100644
index 000000000000..458d0edf5edc
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+PYTHON_REQ_USE="sqlite,ssl,xml"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# tests require network access
+RESTRICT="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+src_compile() {
+ emake data/completion/gallery-dl
+ emake data/completion/_gallery-dl
+ emake man
+ distutils-r1_src_compile
+}
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}
diff --git a/net-misc/gallery-dl/metadata.xml b/net-misc/gallery-dl/metadata.xml
new file mode 100644
index 000000000000..955798794c34
--- /dev/null
+++ b/net-misc/gallery-dl/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mikf/gallery-dl</remote-id>
+ </upstream>
+ <longdescription>
+ gallery-dl is a command-line program to download image-galleries and -collections from several image hosting sites.
+ It is a cross-platform tool with many configuration options and powerful filenaming capabilities.
+ </longdescription>
+</pkgmetadata>