summaryrefslogtreecommitdiff
path: root/net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild b/net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild
new file mode 100644
index 000000000000..c656088b952d
--- /dev/null
+++ b/net-misc/grive/grive-0.5.2_pre20211128-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="6901fbb169eaae51acb61778760ba2ac019675ae"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ dev-libs/yajl
+ || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/363.patch" )