summaryrefslogtreecommitdiff
path: root/net-misc/hath/hath-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-misc/hath/hath-0.5.0.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-misc/hath/hath-0.5.0.ebuild')
-rw-r--r--net-misc/hath/hath-0.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/hath/hath-0.5.0.ebuild b/net-misc/hath/hath-0.5.0.ebuild
new file mode 100644
index 000000000000..fe89595f889f
--- /dev/null
+++ b/net-misc/hath/hath-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hath manipulates network blocks in CIDR notation"
+HOMEPAGE="http://michael.orlitzky.com/code/hath.xhtml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cmdargs-0.10:=
+ >=dev-haskell/split-0.2:=
+ >=dev-haskell/tasty-0.8:=
+ >=dev-haskell/tasty-hunit-0.8:=
+ >=dev-haskell/tasty-quickcheck-0.8.1:=
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-util/shelltestrunner )
+"
+
+src_install() {
+ cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}