summaryrefslogtreecommitdiff
path: root/net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild')
-rw-r--r--net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild b/net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild
new file mode 100644
index 000000000000..ca13bb0f66ce
--- /dev/null
+++ b/net-misc/ipsorcery/ipsorcery-2.0.9-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Ipsorcery allows you to generate IP, TCP, UDP, ICMP, and IGMP packets"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="mirror://gentoo/ipsorc-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND="
+ gtk? (
+ dev-libs/glib:2=
+ x11-libs/gtk+:2=
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+S=${WORKDIR}/ipsorc-${PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-_BSD_SOURCE.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ con $(usex gtk gtk '')
+}
+
+src_install() {
+ dosbin ipmagic $(usex gtk magic '')
+ dodoc BUGS changelog HOWTO README
+}