summaryrefslogtreecommitdiff
path: root/net-misc/istioctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /net-misc/istioctl
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'net-misc/istioctl')
-rw-r--r--net-misc/istioctl/Manifest3
-rw-r--r--net-misc/istioctl/istioctl-1.0.2.ebuild35
-rw-r--r--net-misc/istioctl/metadata.xml11
3 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/istioctl/Manifest b/net-misc/istioctl/Manifest
new file mode 100644
index 000000000000..171521589b20
--- /dev/null
+++ b/net-misc/istioctl/Manifest
@@ -0,0 +1,3 @@
+DIST istioctl-1.0.2.tar.gz 18828091 BLAKE2B 064e9ad8b2629809c7b55514ad0a537bae8785bfebabea610a54ead0a0e665cdc718218376e07dcf5e235f8674bdd9e2eaa7a79bfd5d5485a5ddc841e1c52527 SHA512 d444dd8e0676ac9b36dc3901595f15d6504991619a82057f924141f752d2a45866df9ca388d6c63e1fbe43be4d4156f3efc748be59b565f865a0c5b3d02bda07
+EBUILD istioctl-1.0.2.ebuild 881 BLAKE2B 00a7f516e13770c040062a00ed69f81978dd417bc99110642ae0be829db843f3102702d66dfffe25c0dd47cece882b0a32b1bfce7156e7f6f90d4e90722597db SHA512 4d97bd6fc977531321d9ad406b39e13546eabd2029887422acae435de2fc6c0e0c6d805ca8de15cde59392750a7862a561266b27cc7ad1ef0418816a104946d6
+MISC metadata.xml 321 BLAKE2B 46078d652e4352893c239c5e6b7d30a160f48b370f932357a5c2940c67ddae2f6c932ca6dd1b0b784b0e2a03a7649936ebe317dc95da5ad7a9acbd2e497a01d1 SHA512 cb45dda3fe092fbc1d18cdd21f44ad5cd89c51fee4e10aee6140bd66b25e46c9253672b8f36fe0ae6a83ff9a76c9b1bd35de59846abb9054b1f5095e33858d88
diff --git a/net-misc/istioctl/istioctl-1.0.2.ebuild b/net-misc/istioctl/istioctl-1.0.2.ebuild
new file mode 100644
index 000000000000..4f3d1ba3c9a5
--- /dev/null
+++ b/net-misc/istioctl/istioctl-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="d639408fded355fb906ef2a1f9e8ffddc24c3d64"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+ istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+ istio.io/istio/pkg/version.buildStatus=Clean" \
+ VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+ popd || die
+}
+
+src_install() {
+ dobin out/linux_amd64/release/${PN}
+ pushd "src/${EGO_PN}" || die
+ dodoc README.md
+}
diff --git a/net-misc/istioctl/metadata.xml b/net-misc/istioctl/metadata.xml
new file mode 100644
index 000000000000..25597e3863fd
--- /dev/null
+++ b/net-misc/istioctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">istio/istio</remote-id>
+ </upstream>
+</pkgmetadata>