summaryrefslogtreecommitdiff
path: root/net-misc/netkit-bootparamd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 17:03:45 +0100
commitc9e9e39938097bf29063c271195ad0d7d7bd02a9 (patch)
treef2f4ab36d22272fec3a1d1313d8f700b1f0f6744 /net-misc/netkit-bootparamd
parent0968caae52d6eae7513e2ce4e0900a2e009780ee (diff)
gentoo auto-resync : 17:09:2023 - 17:03:44
Diffstat (limited to 'net-misc/netkit-bootparamd')
-rw-r--r--net-misc/netkit-bootparamd/Manifest1
-rw-r--r--net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/netkit-bootparamd/Manifest b/net-misc/netkit-bootparamd/Manifest
index f556b203f1e5..67521bffd1f9 100644
--- a/net-misc/netkit-bootparamd/Manifest
+++ b/net-misc/netkit-bootparamd/Manifest
@@ -4,4 +4,5 @@ AUX bootparamd.confd 29 BLAKE2B a2697cebfe9e2c7a9617b2624b70d0615b4ad920d034dbd0
AUX bootparamd.initd 502 BLAKE2B ebc4d4c3381c1003924c402415aea4ad820e24f38520b4f0bc41643dc3f24642e8010907ae1451f7286607ab387d256e9e74f43ca53c5f3677e876956d0a686f SHA512 9326e3a3dfca43cd7233a289b1f58c22db22aabc2136cba2d61a4bdab17652f9d031e4eddc877126aa09e08e048e63ba9fcf4219f9dbbf55d6787e03d5ee2548
DIST netkit-bootparamd_0.17.orig.tar.gz 13934 BLAKE2B d828175594b0aae60c5284d4f02c73b4bb91cee2601dc52c6cbfb21e02779825a03567de7dbcc945246104889b7b4bc74f0429b508bda082a365a1d605e213e5 SHA512 fc237c72efd0c7a671c179ee4596f64e13a7a637441d32c9e82e81f4133d987f468c98b00611fbada1f7d6e5fa791c9b513978bfc7a58efe7d93102a2d3b4dca
EBUILD netkit-bootparamd-0.17-r4.ebuild 1454 BLAKE2B cb36308c62f7fe7186037150233352d2a780c52b13d94df3bdd4ae1ea016f3e6742c14899fb8b51b654eb3b94c703ec27121c42c625ef722202481396b6e617a SHA512 a48c201c0aa38f861ed0e5677a404814d5ebdb3c17079763d335e75fcc7c47a770f93d8567ff1a5f161a27a2d09d946e8de0dc533eb1030ff16372ff4013d9b9
+EBUILD netkit-bootparamd-0.17-r5.ebuild 1479 BLAKE2B 0af8ed8db970c1fe0e39477a84784f686a530112b520ef9f771c7190a68b72d7a8f8427da7aa9ce5078e0ea650956e903900d3870dcd73f92b1f509693c086b0 SHA512 2fb787255ad0f4177bb1265c9c9c6fb228c59594dec251915a1a1080609dbec02faed41b821e8faf8d07e38072f9e7e091bbb20d4af6a14de7bcb1d21fea3847
MISC metadata.xml 268 BLAKE2B 91c62a36cbf68e44d577a77084141c8505ad6f4f4d0455c4e68aa99e758518505c09161acc56f77de536d94e05b22ed8f6eff2f61d4a1744e1e752d24ba785f1 SHA512 e08f7d0f198f125c9a66e8503eab99802b27d5bd5c2cfd99c03d9acc3bcc67e404c44945dd4271fed3257b123492ead2492cbce645dbf383ffc0b684a5050bb1
diff --git a/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild
new file mode 100644
index 000000000000..59faca2de934
--- /dev/null
+++ b/net-misc/netkit-bootparamd/netkit-bootparamd-0.17-r5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Netkit - bootparamd: Net-boot support daemon"
+HOMEPAGE="https://wiki.linuxfoundation.org/networking/netkit"
+SRC_URI="mirror://debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="+libtirpc"
+
+DEPEND="
+ !<=net-misc/netkit-bootpd-0.17-r2
+ libtirpc? ( net-libs/rpcsvc-proto net-libs/libtirpc )
+ !libtirpc? ( sys-libs/glibc[rpc(-)] )
+"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/0.17-jumpstart.patch
+ "${FILESDIR}"/0.17-libtirpc.patch
+)
+
+src_prepare() {
+ # don't reset LDFLAGS (bug #335457), manpages into /usr/share/man
+ sed -i -e '/^LDFLAGS=/d ; /MANDIR=/s:man:share/man:' configure || die
+ sed -i -e 's:install -s:install:' rpc.bootparamd/Makefile || die
+ default
+}
+
+src_configure() {
+ if use libtirpc ; then
+ append-cflags -I/usr/include/tirpc
+ sed -i -e 's:^LIBS=$:LIBS=-ltirpc:' configure || die
+ fi
+
+ # Note this is not an autoconf configure
+ CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" ./configure || die
+}
+
+src_install() {
+ dodir usr/bin usr/sbin usr/share/man/man8
+ emake INSTALLROOT="${D}" install
+
+ newconfd "${FILESDIR}"/bootparamd.confd bootparamd
+ newinitd "${FILESDIR}"/bootparamd.initd bootparamd
+
+ doman rpc.bootparamd/bootparams.5
+ dodoc README ChangeLog
+ newdoc rpc.bootparamd/README README.bootparamd
+}