summaryrefslogtreecommitdiff
path: root/net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild')
-rw-r--r--net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild b/net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild
index 1ef2fda749d3..984a26200b85 100644
--- a/net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.1.7-r1.ebuild
@@ -6,13 +6,13 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} )
PYTHON_REQ_USE='threads(+)'
-inherit flag-o-matic python-r1 waf-utils systemd user
+inherit flag-o-matic python-r1 waf-utils systemd
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
BDEPEND=""
- KEYWORDS="amd64"
+ KEYWORDS=""
else
SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
RESTRICT="mirror"
@@ -48,6 +48,8 @@ RDEPEND="${CDEPEND}
ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
!net-misc/ntp
!net-misc/openntpd
+ acct-group/ntp
+ acct-user/ntp
"
DEPEND="${CDEPEND}
app-text/asciidoc
@@ -60,15 +62,11 @@ DEPEND="${CDEPEND}
WAF_BINARY="${S}/waf"
-pkg_setup() {
- enewgroup ntp 123
- enewuser ntp 123 -1 /dev/null ntp
-}
-
src_prepare() {
default
# Remove autostripping of binaries
sed -i -e '/Strip binaries/d' wscript
+ eapply "${FILESDIR}/${P}"-make-sure-logrotate-config-has-missingok.patch
if ! use libbsd ; then
epatch "${FILESDIR}/${PN}-no-bsd.patch"
fi
@@ -123,6 +121,7 @@ src_install() {
waf-utils_src_install
}
python_foreach_impl run_in_build_dir python_install
+ python_foreach_impl python_optimize
# Install heat generating scripts
use heat && dosbin "${S}"/contrib/ntpheat{,usb}