summaryrefslogtreecommitdiff
path: root/net-misc/nx/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/nx/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/nx/files')
-rw-r--r--net-misc/nx/files/1.5.0/nxcomp-1.5.0-pic.patch20
-rw-r--r--net-misc/nx/files/nx-3.2.0-nxproxy_read_from_stdin.patch68
-rw-r--r--net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch100
-rw-r--r--net-misc/nx/files/nx-3.5.0.30-fix_X11_underlinking.patch11
4 files changed, 199 insertions, 0 deletions
diff --git a/net-misc/nx/files/1.5.0/nxcomp-1.5.0-pic.patch b/net-misc/nx/files/1.5.0/nxcomp-1.5.0-pic.patch
new file mode 100644
index 000000000000..2ccaf978dd09
--- /dev/null
+++ b/net-misc/nx/files/1.5.0/nxcomp-1.5.0-pic.patch
@@ -0,0 +1,20 @@
+--- nxcomp/Makefile.in.agriffis 2005-11-12 12:48:42.000000000 -0500
++++ nxcomp/Makefile.in 2005-12-15 12:24:46.000000000 -0500
+@@ -32,7 +32,7 @@
+
+ CXX = @CXX@
+ CXXFLAGS = @CXXFLAGS@ @X_CFLAGS@ @DEFS@ \
+- -Wall -Wpointer-arith
++ -Wall -Wpointer-arith -fPIC
+ CXXINCLUDES =
+ CXXDEFINES =
+
+@@ -42,7 +42,7 @@
+
+ CC = @CC@
+ CCFLAGS = @CFLAGS@ @X_CFLAGS@ @DEFS@ \
+- -Wall -Wpointer-arith
++ -Wall -Wpointer-arith -fPIC
+ CCINCLUDES =
+ CCDEFINES =
+
diff --git a/net-misc/nx/files/nx-3.2.0-nxproxy_read_from_stdin.patch b/net-misc/nx/files/nx-3.2.0-nxproxy_read_from_stdin.patch
new file mode 100644
index 000000000000..bce692d10a7a
--- /dev/null
+++ b/net-misc/nx/files/nx-3.2.0-nxproxy_read_from_stdin.patch
@@ -0,0 +1,68 @@
+--- Main.c.old 2007-07-18 17:39:13.000000000 +0200
++++ Main.c 2008-03-12 04:40:30.000000000 +0100
+@@ -36,28 +36,48 @@
+ int result = -1;
+
+ char *options = NULL;
+-
++
++ char *nx_commfd_str = NULL;
++
+ options = getenv("NX_DISPLAY");
+-
+- if (NXTransParseCommandLine(argc, argv) < 0)
++
++ if ((nx_commfd_str = getenv("NX_COMMFD")) != NULL)
+ {
+- NXTransCleanup();
+- }
++ int nx_commfd = atoi(nx_commfd_str);
+
+- if (NXTransParseEnvironment(options, 0) < 0)
+- {
+- NXTransCleanup();
++ if (result)
++ result = NXTransCreate(nx_commfd, NX_MODE_SERVER, options);
++
++ // go into endless loop
++
++ if (result)
++ {
++ while (NXTransRunning(NX_FD_ANY))
++ result = NXTransContinue(NULL);
++ }
+ }
++ else
++ {
++ if (NXTransParseCommandLine(argc, argv) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ if (NXTransParseEnvironment(options, 0) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ /*
++ * This should not return...
++ */
++
++ #ifdef TEST
++ fprintf(stderr, "Main: Yielding control to NX entry point.\n");
++ #endif
+
+- /*
+- * This should not return...
+- */
+-
+- #ifdef TEST
+- fprintf(stderr, "Main: Yielding control to NX entry point.\n");
+- #endif
+-
+- result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ }
+
+ /*
+ * ...So these should not be called.
diff --git a/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch b/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch
new file mode 100644
index 000000000000..668a6bf4c310
--- /dev/null
+++ b/net-misc/nx/files/nx-3.5.0.17-cflags_ar_ranlib.patch
@@ -0,0 +1,100 @@
+diff -Naur nx-libs-3.5.0.17.orig/nxcomp/Makefile.in nx-libs-3.5.0.17/nxcomp/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcomp/Makefile.in 2013-01-09 15:03:33.152952758 +0100
++++ nx-libs-3.5.0.17/nxcomp/Makefile.in 2013-01-09 15:05:39.771898159 +0100
+@@ -243,8 +243,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBCYGSHARED): $(LIBARCHIVE)
+ $(CC) -shared -o $(LIBCYGSHARED) \
+diff -Naur nx-libs-3.5.0.17.orig/nxcomp/configure.in nx-libs-3.5.0.17/nxcomp/configure.in
+--- nx-libs-3.5.0.17.orig/nxcomp/configure.in 2013-01-09 15:03:33.151952758 +0100
++++ nx-libs-3.5.0.17/nxcomp/configure.in 2013-01-09 15:04:03.312940892 +0100
+@@ -7,8 +7,7 @@
+
+ dnl Set our default compilation flags.
+
+-CXXFLAGS="$CXXFLAGS -O3 -fno-rtti -fno-exceptions"
+-CFLAGS="$CFLAGS -O3"
++CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
+
+ dnl Reset default linking directives.
+
+diff -Naur nx-libs-3.5.0.17.orig/nxcompext/Makefile.in nx-libs-3.5.0.17/nxcompext/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcompext/Makefile.in 2013-01-09 15:03:33.164952753 +0100
++++ nx-libs-3.5.0.17/nxcompext/Makefile.in 2013-01-09 15:06:08.747879052 +0100
+@@ -125,8 +125,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBCYGSHARED): $(LIBARCHIVE)
+ $(CC) -shared -o $(LIBCYGSHARED) \
+diff -Naur nx-libs-3.5.0.17.orig/nxcompext/configure.in nx-libs-3.5.0.17/nxcompext/configure.in
+--- nx-libs-3.5.0.17.orig/nxcompext/configure.in 2013-01-09 15:03:33.164952753 +0100
++++ nx-libs-3.5.0.17/nxcompext/configure.in 2013-01-09 15:04:16.247935801 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(NXlib.h)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CFLAGS="$CFLAGS -O3"
+-
+ dnl Reset default linking directives.
+
+ LIBSTATIC=""
+diff -Naur nx-libs-3.5.0.17.orig/nxcompshad/Makefile.in nx-libs-3.5.0.17/nxcompshad/Makefile.in
+--- nx-libs-3.5.0.17.orig/nxcompshad/Makefile.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxcompshad/Makefile.in 2013-01-09 15:06:16.933873660 +0100
+@@ -158,8 +158,8 @@
+
+ $(LIBARCHIVE): $(CXXOBJ) $(COBJ)
+ rm -f $(LIBARCHIVE)
+- ar clq $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
+- ranlib $(LIBARCHIVE)
++ $(AR) $(LIBARCHIVE) $(CXXOBJ) $(COBJ)
++ $(RANLIB) $(LIBARCHIVE)
+
+ $(LIBDLL): $(LIBARCHIVE)
+ $(CC) -o $@ \
+diff -Naur nx-libs-3.5.0.17.orig/nxcompshad/configure.in nx-libs-3.5.0.17/nxcompshad/configure.in
+--- nx-libs-3.5.0.17.orig/nxcompshad/configure.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxcompshad/configure.in 2013-01-09 15:04:20.073934295 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(Shadow.h)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CPPFLAGS="$CPPFLAGS -O3"
+-
+ dnl Reset default linking directives.
+
+ LIBSTATIC=""
+diff -Naur nx-libs-3.5.0.17.orig/nxproxy/configure.in nx-libs-3.5.0.17/nxproxy/configure.in
+--- nx-libs-3.5.0.17.orig/nxproxy/configure.in 2013-01-09 15:03:33.163952754 +0100
++++ nx-libs-3.5.0.17/nxproxy/configure.in 2013-01-09 15:04:24.842932418 +0100
+@@ -5,11 +5,6 @@
+ AC_INIT(Main.c)
+ AC_PREREQ(2.13)
+
+-dnl Reset default compilation flags.
+-
+-CXXFLAGS="$CXXFLAGS -O3"
+-CPPFLAGS="$CPPFLAGS -O3"
+-
+ dnl Prefer headers and libraries from nx-X11 if present.
+
+ if test -d "../nx-X11/exports/include" ; then
diff --git a/net-misc/nx/files/nx-3.5.0.30-fix_X11_underlinking.patch b/net-misc/nx/files/nx-3.5.0.30-fix_X11_underlinking.patch
new file mode 100644
index 000000000000..87d73c5a8d37
--- /dev/null
+++ b/net-misc/nx/files/nx-3.5.0.30-fix_X11_underlinking.patch
@@ -0,0 +1,11 @@
+--- nx-X11/lib/X11/Imakefile.orig 2015-04-24 15:24:36.171666957 +0200
++++ nx-X11/lib/X11/Imakefile 2015-04-24 15:25:17.516179627 +0200
+@@ -107,7 +107,7 @@
+ EXCLUDE_SYMBOL = -Wl,--exclude-symbol,XdmcpWrap:_XdmcpWrapperToOddParity
+ #endif
+
+-REQUIREDLIBS=$(REQUIREDX11LIBS) $(REQUIREDI18NLIBS) $(EXCLUDE_SYMBOL) $(NX_REQUIREDLIBS)
++REQUIREDLIBS=$(REQUIREDX11LIBS) $(REQUIREDI18NLIBS) $(EXCLUDE_SYMBOL) $(NX_REQUIREDLIBS) -ldl
+
+ #if defined(MacIIArchitecture) || defined(SequentArchitecture) || defined(i386ScoArchitecture)
+ XBSDLIB = /**/