summaryrefslogtreecommitdiff
path: root/net-misc/nyx/nyx-2.1.0-r6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 22:26:54 +0100
commitb50dd652d8e73a93ecd53b7520f2e841a05911f0 (patch)
tree4bc388dbb23631151ca68bacfd264f9ccbf89006 /net-misc/nyx/nyx-2.1.0-r6.ebuild
parent3221bf225fb68a31e281fcdbfde4cea0d576d946 (diff)
gentoo auto-resync : 06:09:2023 - 22:26:53
Diffstat (limited to 'net-misc/nyx/nyx-2.1.0-r6.ebuild')
-rw-r--r--net-misc/nyx/nyx-2.1.0-r6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-2.1.0-r6.ebuild b/net-misc/nyx/nyx-2.1.0-r6.ebuild
new file mode 100644
index 000000000000..4211aadc685b
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0-r6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='ncurses,sqlite(-)'
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+ inherit pypi
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# net-libs/stem-1.8.0_p20211118 was an incompatible git-snapshot
+# simply depend on net-libs/stem in the future
+RDEPEND="
+ net-libs/stem[${PYTHON_USEDEP}]
+ net-vpn/tor"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # bug #645336
+ doman nyx.1
+}