summaryrefslogtreecommitdiff
path: root/net-misc/oidc-agent/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /net-misc/oidc-agent/files
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'net-misc/oidc-agent/files')
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch48
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch51
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.0.2_install-perms.patch60
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-liblist-automagic.patch11
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-toolchain-vars.patch43
5 files changed, 114 insertions, 99 deletions
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch
deleted file mode 100644
index dda1ab252214..000000000000
--- a/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-1. Support user-provided values of CC, CFLAGS and LDFLAGS
-2. Do not force the use of a static version of libsodium
-
---- a/Makefile
-+++ b/Makefile
-@@ -54,20 +54,20 @@
- endif
-
- # Compiler options
--CC = gcc
-+CC := $(CC)
- # compiling flags here
--CFLAGS = -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra
-+CFLAGS := $(CFLAGS) -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra
- ifndef MAC_OS
- CFLAGS += $(shell pkg-config --cflags libsecret-1)
- endif
- TEST_CFLAGS = $(CFLAGS) -I.
-
- # Linker options
--LINKER = gcc
-+LINKER := $(CC)
- ifdef MAC_OS
- LFLAGS = -lsodium -largp
- else
--LFLAGS = -l:libsodium.a -lseccomp
-+LFLAGS := $(LDFLAGS) -lsodium -lseccomp
- endif
- ifdef HAS_CJSON
- LFLAGS += -lcjson
-@@ -81,7 +81,7 @@
- ifdef MAC_OS
- CLIENT_LFLAGS = -L$(APILIB) -largp -loidc-agent.$(LIBVERSION)
- else
--CLIENT_LFLAGS = -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lseccomp
-+CLIENT_LFLAGS = $(LDFLAGS) -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lseccomp
- endif
- ifdef HAS_CJSON
- CLIENT_LFLAGS += -lcjson
-@@ -478,7 +478,7 @@
- ifdef MAC_OS
- @gcc -dynamiclib -fpic -Wl, -o $@ $(PIC_OBJECTS) -lc
- else
-- @gcc -shared -fpic -Wl,-soname,$(SONAME) -o $@ $(PIC_OBJECTS) -lc
-+ @$(LINKER) -shared -fpic -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(PIC_OBJECTS) -lc
- endif
-
- .PHONY: shared_lib
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch
deleted file mode 100644
index b43f20c06860..000000000000
--- a/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- a/test/src/utils/stringUtils/tc_strelim.c
-+++ b/test/src/utils/stringUtils/tc_strelim.c
-@@ -7,7 +7,7 @@
-
- START_TEST(test_noFound) {
- const char* const str = "abcdeffedcba";
-- char s[strlen(str)];
-+ char s[strlen(str) + 1];
- strcpy(s, str);
- ck_assert_str_eq(strelim(s, 'x'), str);
- }
---- a/test/src/utils/stringUtils/tc_strelimIfAfter.c
-+++ b/test/src/utils/stringUtils/tc_strelimIfAfter.c
-@@ -7,7 +7,7 @@
-
- START_TEST(test_noElim) {
- const char* const str = "abcdeffedcba";
-- char s[strlen(str)];
-+ char s[strlen(str) + 1];
- strcpy(s, str);
- ck_assert_str_eq(strelimIfAfter(s, 'b', 'x'), str);
- }
-@@ -15,7 +15,7 @@
-
- START_TEST(test_noFound) {
- const char* const str = "abcdeffedcba";
-- char s[strlen(str)];
-+ char s[strlen(str) + 1];
- strcpy(s, str);
- ck_assert_str_eq(strelimIfAfter(s, 'x', 'a'), str);
- }
---- a/test/src/utils/stringUtils/tc_strelimIfFollowed.c
-+++ b/test/src/utils/stringUtils/tc_strelimIfFollowed.c
-@@ -7,7 +7,7 @@
-
- START_TEST(test_noElim) {
- const char* const str = "abcdeffedcba";
-- char s[strlen(str)];
-+ char s[strlen(str) + 1];
- strcpy(s, str);
- ck_assert_str_eq(strelimIfFollowed(s, 'b', 'x'), str);
- }
-@@ -15,7 +15,7 @@
-
- START_TEST(test_noFound) {
- const char* const str = "abcdeffedcba";
-- char s[strlen(str)];
-+ char s[strlen(str) + 1];
- strcpy(s, str);
- ck_assert_str_eq(strelimIfFollowed(s, 'x', 'a'), str);
- }
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.0.2_install-perms.patch b/net-misc/oidc-agent/files/oidc-agent-4.0.2_install-perms.patch
new file mode 100644
index 000000000000..6184f42d9335
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.0.2_install-perms.patch
@@ -0,0 +1,60 @@
+--- a/Makefile
++++ b/Makefile
+@@ -411,19 +411,19 @@
+
+ ## Man pages
+ $(MAN_PATH)/man1/$(AGENT).1: $(MANDIR)/$(AGENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(AGENTSERVER_MAN_PATH)/man1/$(AGENTSERVER).1: $(MANDIR)/$(AGENTSERVER).1 $(AGENTSERVER_MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(GEN).1: $(MANDIR)/$(GEN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(ADD).1: $(MANDIR)/$(ADD).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(CLIENT).1: $(MANDIR)/$(CLIENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(KEYCHAIN).1: $(MANDIR)/$(KEYCHAIN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(PROMPT_MAN_PATH)/man1/$(PROMPT).1: $(MANDIR)/$(PROMPT).1 $(PROMPT_MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+
+
+ ## Lib
+@@ -437,24 +437,24 @@
+ @ln -sf $(SHARED_LIB_NAME_SO) $@
+
+ $(INCLUDE_PATH)/oidc-agent/api.h: $(SRCDIR)/$(CLIENT)/api.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/ipc_values.h: $(SRCDIR)/defines/ipc_values.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/oidc_error.h: $(SRCDIR)/utils/oidc_error.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(LIBDEV_PATH)/liboidc-agent.a: $(APILIB)/liboidc-agent.a $(LIBDEV_PATH)
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/export_symbols.h: $(SRCDIR)/$(CLIENT)/export_symbols.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+
+ ## scheme handler
+ $(DESKTOP_APPLICATION_PATH)/oidc-gen.desktop: $(CONFDIR)/scheme_handler/oidc-gen.desktop
+- @install -D $< $@
++ @install -m 644 -D $< $@
+ @echo "Exec=x-terminal-emulator -e bash -c \"$(BIN_AFTER_INST_PATH)/bin/$(GEN) --codeExchange=%u; exec bash\"" >> $@
+
+ ## Xsession
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-liblist-automagic.patch b/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-liblist-automagic.patch
new file mode 100644
index 000000000000..1e8765aef9d0
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-liblist-automagic.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -58,7 +58,7 @@
+
+ # USE_CJSON_SO ?= $(shell /sbin/ldconfig -N -v $(sed 's/:/ /g' <<< $LD_LIBRARY_PATH) 2>/dev/null | grep -i libcjson >/dev/null && echo 1 || echo 0)
+ USE_CJSON_SO ?= 0
+-USE_LIST_SO ?= $(shell /sbin/ldconfig -N -v $(sed 's/:/ /g' <<< $LD_LIBRARY_PATH) 2>/dev/null | grep -i liblist >/dev/null && echo 1 || echo 0)
++USE_LIST_SO ?= 0
+
+ ifeq ($(USE_CJSON_SO),1)
+ DEFINE_USE_CJSON_SO = -DUSE_CJSON_SO
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-toolchain-vars.patch b/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-toolchain-vars.patch
new file mode 100644
index 000000000000..533af1f2a6d4
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.0.2_makefile-toolchain-vars.patch
@@ -0,0 +1,43 @@
+--- a/Makefile
++++ b/Makefile
+@@ -74,9 +74,9 @@
+ endif
+
+ # Compiler options
+-CC = gcc
++CC := $(CC)
+ # compiling flags here
+-CFLAGS = -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
++CFLAGS := $(CFLAGS) -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
+ ifndef MAC_OS
+ ifndef NODPKG
+ CFLAGS +=$(shell dpkg-buildflags --get CPPFLAGS)
+@@ -87,11 +87,11 @@
+ TEST_CFLAGS = $(CFLAGS) -I.
+
+ # Linker options
+-LINKER = gcc
++LINKER := $(CC)
+ ifdef MAC_OS
+ LFLAGS = -lsodium -largp
+ else
+-LFLAGS = -lsodium -lseccomp -fno-common
++LFLAGS := $(LDFLAGS) -lsodium -lseccomp -fno-common
+ ifndef NODPKG
+ LFLAGS +=$(shell dpkg-buildflags --get LDFLAGS)
+ endif
+@@ -112,12 +112,12 @@
+ ifdef MAC_OS
+ CLIENT_LFLAGS = -L$(APILIB) -largp -loidc-agent.$(LIBVERSION) -lsodium
+ else
+-CLIENT_LFLAGS = -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lsodium -lseccomp
++CLIENT_LFLAGS := $(LDFLAGS) -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lsodium -lseccomp
+ ifndef NODPKG
+ CLIENT_LFLAGS += $(shell dpkg-buildflags --get LDFLAGS)
+ endif
+ endif
+-LIB_LFLAGS = -lc -lsodium
++LIB_LFLAGS := $(LDFLAGS) -lc -lsodium
+ ifndef MAC_OS
+ ifndef NODPKG
+ LIB_FLAGS += $(shell dpkg-buildflags --get LDFLAGS)