summaryrefslogtreecommitdiff
path: root/net-misc/oidc-agent/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /net-misc/oidc-agent/files
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'net-misc/oidc-agent/files')
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_desktop-category.patch9
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_install-perms.patch58
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch30
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch51
4 files changed, 148 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_desktop-category.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_desktop-category.patch
new file mode 100644
index 000000000000..49bfcfdb70b3
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-3.3.1_desktop-category.patch
@@ -0,0 +1,9 @@
+--- a/config/scheme_handler/oidc-gen.desktop
++++ b/config/scheme_handler/oidc-gen.desktop
+@@ -5,5 +5,5 @@
+ Icon=utilities-terminal
+ Terminal=true
+ Type=Application
+-Categories=Application;Network;
++Categories=Network;
+ MimeType=x-scheme-handler/edu.kit.data.oidc-agent;
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_install-perms.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_install-perms.patch
new file mode 100644
index 000000000000..1992ee0ef31f
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-3.3.1_install-perms.patch
@@ -0,0 +1,58 @@
+--- a/Makefile
++++ b/Makefile
+@@ -316,7 +316,7 @@
+
+ ## Bash completion
+ $(BASH_COMPLETION_PATH)/$(AGENT): $(CONFDIR)/bash-completion/oidc-agent $(BASH_COMPLETION_PATH)
+- @install -m 744 $< $@
++ @install -m 644 $< $@
+
+ $(BASH_COMPLETION_PATH)/$(GEN): $(BASH_COMPLETION_PATH)
+ @ln -s $(AGENT) $@
+@@ -332,15 +332,15 @@
+
+ ## Man pages
+ $(MAN_PATH)/man1/$(AGENT).1: $(MANDIR)/$(AGENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(GEN).1: $(MANDIR)/$(GEN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(ADD).1: $(MANDIR)/$(ADD).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(CLIENT).1: $(MANDIR)/$(CLIENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(KEYCHAIN).1: $(MANDIR)/$(KEYCHAIN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+
+
+ ## Lib
+@@ -354,20 +354,20 @@
+ @ln -sf $(SHARED_LIB_NAME_SO) $@
+
+ $(INCLUDE_PATH)/oidc-agent/api.h: $(SRCDIR)/$(CLIENT)/api.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/ipc_values.h: $(SRCDIR)/defines/ipc_values.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/oidc_error.h: $(SRCDIR)/utils/oidc_error.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(LIBDEV_PATH)/liboidc-agent.a: $(APILIB)/liboidc-agent.a $(LIBDEV_PATH)
+- @install $< $@
++ @install -m 644 $< $@
+
+ ## scheme handler
+ $(DESKTOP_APPLICATION_PATH)/oidc-gen.desktop: $(CONFDIR)/scheme_handler/oidc-gen.desktop
+- @install -D $< $@
++ @install -m 644 -D $< $@
+ @echo "Exec=x-terminal-emulator -e bash -c \"$(BIN_AFTER_INST_PATH)/bin/$(GEN) --codeExchange=%u; exec bash\"" >> $@
+
+ ## Xsession
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch
new file mode 100644
index 000000000000..0cdf44fba8c2
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-3.3.1_makefile-toolchain-vars.patch
@@ -0,0 +1,30 @@
+1. Support user-provided values of CC, CFLAGS and LDFLAGS
+2. Do not force the use of a static version of libsodium
+
+--- a/Makefile
++++ b/Makefile
+@@ -54,20 +54,20 @@
+ endif
+
+ # Compiler options
+-CC = gcc
++CC := $(CC)
+ # compiling flags here
+-CFLAGS = -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra
++CFLAGS := $(CFLAGS) -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra
+ ifndef MAC_OS
+ CFLAGS += $(shell pkg-config --cflags libsecret-1)
+ endif
+ TEST_CFLAGS = $(CFLAGS) -I.
+
+ # Linker options
+-LINKER = gcc
++LINKER := $(CC)
+ ifdef MAC_OS
+ LFLAGS = -lsodium -largp
+ else
+-LFLAGS = -l:libsodium.a -lseccomp
++LFLAGS := $(LDFLAGS) -lsodium -lseccomp
+ endif
+ ifdef HAS_CJSON
+ LFLAGS += -lcjson
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch
new file mode 100644
index 000000000000..b43f20c06860
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-3.3.1_test-suite-buffer-overflows.patch
@@ -0,0 +1,51 @@
+--- a/test/src/utils/stringUtils/tc_strelim.c
++++ b/test/src/utils/stringUtils/tc_strelim.c
+@@ -7,7 +7,7 @@
+
+ START_TEST(test_noFound) {
+ const char* const str = "abcdeffedcba";
+- char s[strlen(str)];
++ char s[strlen(str) + 1];
+ strcpy(s, str);
+ ck_assert_str_eq(strelim(s, 'x'), str);
+ }
+--- a/test/src/utils/stringUtils/tc_strelimIfAfter.c
++++ b/test/src/utils/stringUtils/tc_strelimIfAfter.c
+@@ -7,7 +7,7 @@
+
+ START_TEST(test_noElim) {
+ const char* const str = "abcdeffedcba";
+- char s[strlen(str)];
++ char s[strlen(str) + 1];
+ strcpy(s, str);
+ ck_assert_str_eq(strelimIfAfter(s, 'b', 'x'), str);
+ }
+@@ -15,7 +15,7 @@
+
+ START_TEST(test_noFound) {
+ const char* const str = "abcdeffedcba";
+- char s[strlen(str)];
++ char s[strlen(str) + 1];
+ strcpy(s, str);
+ ck_assert_str_eq(strelimIfAfter(s, 'x', 'a'), str);
+ }
+--- a/test/src/utils/stringUtils/tc_strelimIfFollowed.c
++++ b/test/src/utils/stringUtils/tc_strelimIfFollowed.c
+@@ -7,7 +7,7 @@
+
+ START_TEST(test_noElim) {
+ const char* const str = "abcdeffedcba";
+- char s[strlen(str)];
++ char s[strlen(str) + 1];
+ strcpy(s, str);
+ ck_assert_str_eq(strelimIfFollowed(s, 'b', 'x'), str);
+ }
+@@ -15,7 +15,7 @@
+
+ START_TEST(test_noFound) {
+ const char* const str = "abcdeffedcba";
+- char s[strlen(str)];
++ char s[strlen(str) + 1];
+ strcpy(s, str);
+ ck_assert_str_eq(strelimIfFollowed(s, 'x', 'a'), str);
+ }