summaryrefslogtreecommitdiff
path: root/net-misc/olsrd/olsrd-0.9.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-misc/olsrd/olsrd-0.9.6.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-misc/olsrd/olsrd-0.9.6.1.ebuild')
-rw-r--r--net-misc/olsrd/olsrd-0.9.6.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-misc/olsrd/olsrd-0.9.6.1.ebuild b/net-misc/olsrd/olsrd-0.9.6.1.ebuild
index 1379675e09a0..8e8f409db132 100644
--- a/net-misc/olsrd/olsrd-0.9.6.1.ebuild
+++ b/net-misc/olsrd/olsrd-0.9.6.1.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils multilib toolchain-funcs versionator
+
+inherit toolchain-funcs versionator
DESCRIPTION="An implementation of the Optimized Link State Routing protocol"
HOMEPAGE="http://www.olsr.org/"
SRC_URI="http://www.olsr.org/releases/$(get_version_component_range 1-2)/${P}.tar.bz2"
-SLOT="0"
LICENSE="BSD LGPL-2.1"
+SLOT="0"
KEYWORDS="amd64 x86"
IUSE="gtk pud"
+
DEPEND="
+ virtual/pkgconfig
gtk? (
dev-libs/glib:2
x11-libs/gdk-pixbuf:2
@@ -23,10 +26,12 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0.2-gtk.patch
"${FILESDIR}"/${PN}-0.9.6-gpsd.patch
)
+
src_prepare() {
default
@@ -63,6 +68,7 @@ src_compile() {
OLSRD_LDFLAGS="${LDFLAGS}" \
OS=linux \
build_all
+
if use gtk; then
emake -C gui/linux-gtk LIBDIR="/usr/$(get_libdir)/${PN}" CC="$(tc-getCC)"
fi
@@ -71,6 +77,7 @@ src_compile() {
src_install() {
emake OS=linux LIBDIR="${D}/usr/$(get_libdir)/${PN}" \
DESTDIR="${D}" STRIP=true install_all
+
if use gtk; then
emake -C gui/linux-gtk \
LIBDIR="${D}/usr/$(get_libdir)/${PN}" DESTDIR="${D}" install