summaryrefslogtreecommitdiff
path: root/net-misc/olsrd/olsrd-0.9.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-misc/olsrd/olsrd-0.9.8.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-misc/olsrd/olsrd-0.9.8.ebuild')
-rw-r--r--net-misc/olsrd/olsrd-0.9.8.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-misc/olsrd/olsrd-0.9.8.ebuild b/net-misc/olsrd/olsrd-0.9.8.ebuild
index c9d51ba3119a..bede675037e3 100644
--- a/net-misc/olsrd/olsrd-0.9.8.ebuild
+++ b/net-misc/olsrd/olsrd-0.9.8.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
DESCRIPTION="An implementation of the Optimized Link State Routing protocol"
HOMEPAGE="http://www.olsr.org/"
SRC_URI="https://github.com/OLSR/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SLOT="0"
LICENSE="BSD LGPL-2.1"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk pud"
+
DEPEND="
gtk? (
dev-libs/glib:2
@@ -23,10 +25,13 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0.2-gtk.patch
"${FILESDIR}"/${PN}-0.9.6-gpsd.patch
)
+
src_prepare() {
default
@@ -56,6 +61,7 @@ src_configure() {
src_compile() {
tc-export PKG_CONFIG
+
emake \
CC="$(tc-getCC)" \
LIBDIR="/usr/$(get_libdir)/${PN}" \
@@ -63,6 +69,7 @@ src_compile() {
OS=linux \
VERBOSE=1 \
build_all
+
if use gtk; then
emake -C gui/linux-gtk LIBDIR="/usr/$(get_libdir)/${PN}" CC="$(tc-getCC)"
fi
@@ -76,6 +83,7 @@ src_install() {
OS=linux \
STRIP=true \
install_all
+
if use gtk; then
emake -C gui/linux-gtk \
DESTDIR="${D}" \