summaryrefslogtreecommitdiff
path: root/net-misc/passt/passt-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-21 07:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-21 07:00:13 +0000
commit3faa6ebe0068b432ee5a9390c47ceca068ea7fe9 (patch)
treec571245b455a9a5dd80022270c5ac943532620b9 /net-misc/passt/passt-9999.ebuild
parentee93fbc2bb111cf895ae00cc1877c68f0eafaf2a (diff)
gentoo auto-resync : 21:03:2024 - 07:00:13
Diffstat (limited to 'net-misc/passt/passt-9999.ebuild')
-rw-r--r--net-misc/passt/passt-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-misc/passt/passt-9999.ebuild b/net-misc/passt/passt-9999.ebuild
index 5683bd6f8693..effdc66105d0 100644
--- a/net-misc/passt/passt-9999.ebuild
+++ b/net-misc/passt/passt-9999.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
HOMEPAGE="https://passt.top/"
-RELEASE_COMMIT="b86afe3"
+RELEASE_COMMIT="71dd405"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
@@ -21,6 +23,15 @@ LICENSE="BSD GPL-2+"
SLOT="0"
IUSE="static"
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
src_compile() {
[[ ${PV} != 9999* ]] && export VERSION="${PV}"
export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"