summaryrefslogtreecommitdiff
path: root/net-misc/pcapfix/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /net-misc/pcapfix/files
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'net-misc/pcapfix/files')
-rw-r--r--net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch b/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch
new file mode 100644
index 000000000000..a80419b1a87b
--- /dev/null
+++ b/net-misc/pcapfix/files/pcapfix-1.1.7-respect-CFLAGS.patch
@@ -0,0 +1,21 @@
+https://github.com/Rup0rt/pcapfix/pull/27
+
+From: Sam James <sam@gentoo.org>
+Date: Wed, 29 Dec 2021 06:48:09 +0000
+Subject: [PATCH] build: respect CFLAGS
+
+Allow overriding in the environment by using our value
+as just a default.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ MANDIR ?= $(PREFIX)/share/man
+ OPTFLAGS = $(shell getconf LFS_CFLAGS) -D_FORTIFY_SOURCE=2 -O2 -fstack-protector --param=ssp-buffer-size=4
+ WARNFLAGS = -Wall -Wextra -std=gnu99 -pedantic -Wformat -Werror=format-security
+ DEBUGFLAGS = -g
+-CFLAGS += $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS)
++CFLAGS ?= $(OPTFLAGS) $(WARNFLAGS) $(DEBUGFLAGS)
+
+ # Determine extra LDFLAGS
+ OS := $(shell uname)