summaryrefslogtreecommitdiff
path: root/net-misc/portfwd/portfwd-0.29-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/portfwd/portfwd-0.29-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/portfwd/portfwd-0.29-r1.ebuild')
-rw-r--r--net-misc/portfwd/portfwd-0.29-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/portfwd/portfwd-0.29-r1.ebuild b/net-misc/portfwd/portfwd-0.29-r1.ebuild
new file mode 100644
index 000000000000..30e0f893ba17
--- /dev/null
+++ b/net-misc/portfwd/portfwd-0.29-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils systemd
+
+DESCRIPTION="Port Forwarding Daemon"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://portfwd.sourceforge.net"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ia64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ cd src
+ sed -iorig \
+ -e "s:^CFLAGS =.*:CFLAGS = @CFLAGS@ -Wall -DPORTFWD_CONF=\\\\\"\$(sysconfdir)/portfwd.cfg\\\\\":" \
+ -e "s:^CXXFLAGS =.*:CPPFLAGS = @CXXFLAGS@ -Wall -DPORTFWD_CONF=\\\\\"\$(sysconfdir)/portfwd.cfg\\\\\":" \
+ Makefile.am || die
+ cd ../tools
+ sed -iorig \
+ -e "s:^CXXFLAGS =.*:CPPFLAGS = @CXXFLAGS@ -Wall -DPORTFWD_CONF=\\\\\"\$(sysconfdir)/portfwd.cfg\\\\\":" \
+ Makefile.am || die
+ cd ../getopt
+ sed -iorig -e "s:$.CC.:\$(CC) @CFLAGS@:g" Makefile.am || die
+ cd ../doc
+ sed -iorig -e "s:/doc/portfwd:/share/doc/$P:" Makefile.am || die
+ cd ..
+ sed -iorig -e "s:/doc/portfwd:/share/doc/$P:" Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc cfg/*
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}