summaryrefslogtreecommitdiff
path: root/net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
commit9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (patch)
treeb70c1d27324b2ed33e5688d4a21f6c5195032ecf /net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild
parent1cf3f23200484257eaf7d863e323e7e9aee98d2b (diff)
gentoo auto-resync : 24:12:2022 - 14:02:21
Diffstat (limited to 'net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild')
-rw-r--r--net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild b/net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..d279c9009305
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-1.0.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="https://github.com/redlab-i/pps-tools"
+SRC_URI="https://github.com/redlab-i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ppc ppc64 ~riscv ~sparc x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-build.patch
+ "${FILESDIR}"/${PN}-1.0.1-install.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}