summaryrefslogtreecommitdiff
path: root/net-misc/pulseaudio-dlna
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-misc/pulseaudio-dlna
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-misc/pulseaudio-dlna')
-rw-r--r--net-misc/pulseaudio-dlna/Manifest4
-rw-r--r--net-misc/pulseaudio-dlna/pulseaudio-dlna-0.6.5_p1.ebuild69
-rw-r--r--net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild36
3 files changed, 88 insertions, 21 deletions
diff --git a/net-misc/pulseaudio-dlna/Manifest b/net-misc/pulseaudio-dlna/Manifest
index 4384ae097a7d..d0dc8cdd94a2 100644
--- a/net-misc/pulseaudio-dlna/Manifest
+++ b/net-misc/pulseaudio-dlna/Manifest
@@ -1,3 +1,5 @@
AUX pulseaudio-dlna.desktop 300 BLAKE2B 47eba4d57809eed44acd5df2ce2b9333bede1713f9d291009888427c8ad507cec4a39472cee7422c4f689916b55935935d4b790c3a7ea9778e200d51cdc37fbe SHA512 f8c396e08d387c72fc60a278e40525da1922ca85ed87133538ceb2f0452c34db6da12412c65abd803702fb4a049588e7e3d47b43610e0f52ee0499323c4341b3
-EBUILD pulseaudio-dlna-9999.ebuild 2067 BLAKE2B a43c11f87255006748705f6050518b3876ebc9005b4e3be7741f756f214228c535506d12e5b0edae2dc99878ec9997eb186552308f463b50625f5dbc27e0c36c SHA512 e5f090bfc9e7bf5182d83e45fb81a5322766de05b07047bce9c177c0e1b08df83c6460469969c6142338eb6490c9c27c615644e56a649c9db53ff3f226da5e92
+DIST pulseaudio-dlna-0.6.5-1.tar.gz 712483 BLAKE2B baf1fc94f41c9ac2ca7df5c239ace36b36da4d7a40e30cf19fa630f51a0e94fa44a1ba531943ad5c4425580e4bbe68af1d5de48f5f17163783aab7b471faa72e SHA512 6fd59ac6ff0dfa98baed7a5d929c6f7d9f3539016a6383770895732f7066bc260b3d56751691573d0834a0ee29a6e542ef26e66e48c7a7af97cc84ca23ff5c2d
+EBUILD pulseaudio-dlna-0.6.5_p1.ebuild 1836 BLAKE2B 1b355dbf1fcd98a627b2fce84f55342f403bd4bf756dbeee46da5e4a50b2ec73c4cbeb71fd0a6ffb2f146b9c15ee7a36ecf6ccd9160354c3410b9b7a30d6f67b SHA512 5b15828f051ad7ae26f5be2a8721890283a2f7e63ddce6400c0d63ecbb9c09e03405ec69adb11426cb345e43ac6a8e8149a39269de1689eaf0d8602ad0f1ffa4
+EBUILD pulseaudio-dlna-9999.ebuild 1836 BLAKE2B 1b355dbf1fcd98a627b2fce84f55342f403bd4bf756dbeee46da5e4a50b2ec73c4cbeb71fd0a6ffb2f146b9c15ee7a36ecf6ccd9160354c3410b9b7a30d6f67b SHA512 5b15828f051ad7ae26f5be2a8721890283a2f7e63ddce6400c0d63ecbb9c09e03405ec69adb11426cb345e43ac6a8e8149a39269de1689eaf0d8602ad0f1ffa4
MISC metadata.xml 341 BLAKE2B 9add00de1558ff7ed828022b6e7818de975fb233b6b821f9c7bded156081dfd5edca2ae3237fa3cd2324aa615c6ed02008727a002ddb7b3331f6dd25a2ffcabc SHA512 58ad5457eb2dd3c0f926f32f40433899b1fe2a0456136d0b37b45ae3628994349bd60984e83388514e58b778b6c070ab99c53673f56bd1b7c03a927f1e4afe42
diff --git a/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.6.5_p1.ebuild b/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.6.5_p1.ebuild
new file mode 100644
index 000000000000..cc609b92ede5
--- /dev/null
+++ b/net-misc/pulseaudio-dlna/pulseaudio-dlna-0.6.5_p1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit desktop distutils-r1
+
+DESCRIPTION="A lightweight DLNA/UPNP/Chromecast streaming server for PulseAudio"
+HOMEPAGE="https://github.com/Cygn/pulseaudio-dlna"
+
+if [[ ${PV} == *9999 ]];then
+ EGIT_REPO_URI="https://github.com/Cygn/pulseaudio-dlna"
+ inherit git-r3
+else
+ MY_P=${PN}-${PV/_p/-}
+
+ SRC_URI="https://github.com/Cygn/pulseaudio-dlna/archive/refs/tags/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_P}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/setproctitle-1.1.10[${PYTHON_USEDEP}]
+ >=dev-python/notify2-0.3[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.4.7[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ >=dev-python/pyroute2-0.3.5[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3[${PYTHON_USEDEP}]
+ >=dev-python/pychromecast-10[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ >=dev-python/dbus-python-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.17.4[${PYTHON_USEDEP}]
+ gnome-base/librsvg[introspection]
+ x11-libs/gtk+:3[introspection]
+ || ( media-sound/pulseaudio-daemon media-sound/pulseaudio[daemon(+)] )
+ || (
+ || (
+ media-video/ffmpeg[encode,mp3,opus,vorbis]
+ media-video/ffmpeg[encode,fdk,mp3,opus,vorbis]
+ )
+ (
+ media-libs/flac
+ media-sound/lame
+ media-sound/opus-tools
+ media-sound/sox
+ media-sound/vorbis-tools
+ )
+ )"
+
+python_prepare_all() {
+ sed -i -e 's/.gz//' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}
diff --git a/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild b/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild
index 6fc29c68a643..cc609b92ede5 100644
--- a/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild
+++ b/net-misc/pulseaudio-dlna/pulseaudio-dlna-9999.ebuild
@@ -1,27 +1,29 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit desktop distutils-r1
DESCRIPTION="A lightweight DLNA/UPNP/Chromecast streaming server for PulseAudio"
-HOMEPAGE="https://github.com/masmu/pulseaudio-dlna"
+HOMEPAGE="https://github.com/Cygn/pulseaudio-dlna"
if [[ ${PV} == *9999 ]];then
+ EGIT_REPO_URI="https://github.com/Cygn/pulseaudio-dlna"
inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/masmu/pulseaudio-dlna"
- EGIT_BRANCH="python3"
else
- SRC_URI="https://github.com/masmu/pulseaudio-dlna/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ MY_P=${PN}-${PV/_p/-}
+
+ SRC_URI="https://github.com/Cygn/pulseaudio-dlna/archive/refs/tags/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_P}
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3"
SLOT="0"
-IUSE=""
RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
>=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
@@ -33,13 +35,13 @@ RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
>=dev-python/pyroute2-0.3.5[${PYTHON_USEDEP}]
>=dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
>=dev-python/lxml-3[${PYTHON_USEDEP}]
- >=dev-python/pychromecast-2.3.0[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/pychromecast-10[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
>=dev-python/dbus-python-1.0.0[${PYTHON_USEDEP}]
>=dev-python/zeroconf-0.17.4[${PYTHON_USEDEP}]
- dev-python/pygobject[cairo,${PYTHON_USEDEP}]
gnome-base/librsvg[introspection]
x11-libs/gtk+:3[introspection]
+ || ( media-sound/pulseaudio-daemon media-sound/pulseaudio[daemon(+)] )
|| (
|| (
media-video/ffmpeg[encode,mp3,opus,vorbis]
@@ -54,20 +56,14 @@ RDEPEND=">=dev-python/protobuf-python-2.5.0[${PYTHON_USEDEP}]
)
)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- || ( media-sound/pulseaudio-daemon media-sound/pulseaudio[daemon(+)] )"
-
python_prepare_all() {
- sed -i '/dbus-python/d' setup.py || die
- sed -i '/notify2/d' setup.py || die
- sed -i '/docopt/d' setup.py || die
- sed -i '/pychromecast/d' setup.py || die
+ sed -i -e 's/.gz//' setup.py || die
+
distutils-r1_python_prepare_all
}
src_install() {
distutils-r1_src_install
- domenu "${FILESDIR}/${PN}.desktop"
+ domenu "${FILESDIR}"/${PN}.desktop
}