summaryrefslogtreecommitdiff
path: root/net-misc/r8152/r8152-2.17.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
commit40d8bc05c536b6c3fa0bd58c50480dc79c6b9e92 (patch)
tree390b30b3f1aea86e16973b82eb5fa14406fcab7f /net-misc/r8152/r8152-2.17.1.ebuild
parentfd87b7c771378b2116981e3924bee5805148e118 (diff)
gentoo auto-resync : 22:11:2023 - 23:21:15
Diffstat (limited to 'net-misc/r8152/r8152-2.17.1.ebuild')
-rw-r--r--net-misc/r8152/r8152-2.17.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/r8152/r8152-2.17.1.ebuild b/net-misc/r8152/r8152-2.17.1.ebuild
new file mode 100644
index 000000000000..7d3f7b0a6e6e
--- /dev/null
+++ b/net-misc/r8152/r8152-2.17.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 udev
+
+DESCRIPTION="r8152 driver for Realtek USB FE / GBE / 2.5G Gaming Ethernet Family Controller"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-usb-3-0-software"
+SRC_URI="http://rtitwww.realtek.com/rtdrivers/cn/nic1/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}"
+
+IUSE="+center-tap-short"
+
+# https://github.com/wget/realtek-r8152-linux/ keeps reasonably up to date
+# with kernel support patches. It appears to be used by the AUR maintainer.
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.16.3-kernel-6.4.10-fix.patch
+ "${FILESDIR}"/${PN}-2.16.3-asus-c5000-support.patch
+)
+
+src_compile() {
+ local modlist=( ${PN}=kernel/net/usb:. )
+ local modargs=(
+ KERNELDIR="${KV_OUT_DIR}"
+ CONFIG_CTAP_SHORT="$(usex center-tap-short on off)"
+ )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+ udev_dorules 50-usb-realtek-net.rules
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}