summaryrefslogtreecommitdiff
path: root/net-misc/rdate/rdate-1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-misc/rdate/rdate-1.11.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-misc/rdate/rdate-1.11.ebuild')
-rw-r--r--net-misc/rdate/rdate-1.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/rdate/rdate-1.11.ebuild b/net-misc/rdate/rdate-1.11.ebuild
new file mode 100644
index 000000000000..dd88c82ec3e6
--- /dev/null
+++ b/net-misc/rdate/rdate-1.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="openrdate"
+
+inherit autotools
+
+DESCRIPTION="Use TCP or UDP to retrieve the current time of another machine"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/openrdate"
+SRC_URI="https://github.com/resurrecting-open-source-projects/${MY_P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/rdate-initd-1.4-r3 rdate
+ newconfd "${FILESDIR}"/rdate-confd rdate
+}