summaryrefslogtreecommitdiff
path: root/net-misc/rdate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
commitf300354de9fe5d997850456a9e1f400193e6544f (patch)
tree402fd6a7727db790bf57f683894052e8791d389e /net-misc/rdate
parent5c42677148c717eb9f4673237db807f74740b4e9 (diff)
gentoo auto-resync : 26:08:2024 - 12:00:09
Diffstat (limited to 'net-misc/rdate')
-rw-r--r--net-misc/rdate/Manifest2
-rw-r--r--net-misc/rdate/files/rdate-1.10.2-fix-musl-compat-stdint.patch180
-rw-r--r--net-misc/rdate/files/rdate-1.10.2-respect-AR.patch40
3 files changed, 0 insertions, 222 deletions
diff --git a/net-misc/rdate/Manifest b/net-misc/rdate/Manifest
index e702890c737b..fe81601636f4 100644
--- a/net-misc/rdate/Manifest
+++ b/net-misc/rdate/Manifest
@@ -1,5 +1,3 @@
-AUX rdate-1.10.2-fix-musl-compat-stdint.patch 4574 BLAKE2B 8228b520bc94c1fce70416035ed4eeafb98c96ed05171eed18f914b6d4a6516fc232f9a46cc22e3a9413fa7d1a8dd3837dc2f67e5a8cc0c315fd1ad9a21ce972 SHA512 85c3cc5ead5a5909ac613e37a2ddf7d837dba8a57b162d72ccb473bf679a2c1d4783fcf3e7fd44ca388146ee999d3dc7e63a9a68ab8f1b6203207f39980c5c49
-AUX rdate-1.10.2-respect-AR.patch 1117 BLAKE2B ad992ef817847c39c779eb1a251df905b3a9c0c70487433dcb22014717c4b10486d06237bc2b12b6827c7016321a88950ff8d40a5072b81d5e9bf8a2a0f834cf SHA512 66912901b7b052203af8c39de81aab08f9c512d46c8eaf2174fc936c7bdeb7a045ad56cbfb81b65dca7cb8790c95174b4021ce227289f4e4edb63d21020e9409
AUX rdate-confd 509 BLAKE2B 92826ed23b867063c8cf1145e7a2f62fe6a904593eca1add05971f06773ae992f08e58bb4f5367660e93937baf7bf3d0fe35a508bdaea44bca104c0871cf6ba8 SHA512 1ebc27949cf5c68828e00cacb20644b6c6b0e833c23b4f9e31144f0e47c10daa06b82909198227cdc7018939cbae09f2fe53de69aa84c8b9a8ecb0ab9eaf1f8f
AUX rdate-initd-1.4-r3 525 BLAKE2B 8533f2b589aa860d88a7cdf18931b2a5800a1d82a78db576dfb12189f4b3391535bff5896ef75d6b3ef7373e1ad86c86a82f7422f4c404af8b9b3e414aaad59c SHA512 8563dedff5b2188d5176a882e36d4c8cdab4709ca40e86eb9c76e30f91c3eb78d1da8f971d2c2f4189ef801413e173367d2a8a2b9b37608ef6a84a0e73e39157
DIST rdate-1.11.tar.gz 20210 BLAKE2B 0ff4abebe08f33b45c753dd2912c36e3895c1745b2d78340c7574116f50cd4d05364c5bee97e883b7ad587fcd5261931d928689cd583aa86b43aac408d2a4a6d SHA512 916952c26cdd51c8666bf62cdd823cf8a07fd4487fbf73213d529525b31a90f056120ea2ff16e6d37ea7c662853ba3c15789fef90724b2dbf17c21a6ff3f415d
diff --git a/net-misc/rdate/files/rdate-1.10.2-fix-musl-compat-stdint.patch b/net-misc/rdate/files/rdate-1.10.2-fix-musl-compat-stdint.patch
deleted file mode 100644
index a6ff70b353d5..000000000000
--- a/net-misc/rdate/files/rdate-1.10.2-fix-musl-compat-stdint.patch
+++ /dev/null
@@ -1,180 +0,0 @@
-https://github.com/resurrecting-open-source-projects/openrdate/pull/3
-
-From: Sam James <sam@gentoo.org>
-Date: Thu, 3 Feb 2022 09:23:35 +0000
-Subject: [PATCH] Use <stdint.h> to fix musl compatibility
-
-uint32_t and friends are provided by <stdint.h> and the types
-previously being relied on are non-standard, so let's swap.
-
-This fixes building rdate on e.g. musl rather than glibc.
-
-Bug: https://bugs.gentoo.org/832554
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/src/ntp.c
-+++ b/src/ntp.c
-@@ -52,6 +52,7 @@
- #include <netdb.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <string.h>
- #include <time.h>
- #include <unistd.h>
-@@ -106,11 +107,11 @@ struct ntp_data {
- double receive;
- double transmit;
- double current;
-- u_int64_t recvck;
-+ uint64_t recvck;
-
- /* Local State */
- double originate;
-- u_int64_t xmitck;
-+ uint64_t xmitck;
- };
-
- void ntp_client(const char *, int, struct timeval *, struct timeval *, int, int, int);
-@@ -282,7 +283,7 @@ write_packet(int fd, struct ntp_data *data)
-
- packet[0] = (NTP_VERSION << 3) | (NTP_MODE_CLIENT);
-
-- data->xmitck = (u_int64_t)arc4random() << 32 | arc4random();
-+ data->xmitck = (uint64_t)arc4random() << 32 | arc4random();
-
- /*
- * Send out a random 64-bit number as our transmit time. The NTP
-@@ -300,7 +301,7 @@ write_packet(int fd, struct ntp_data *data)
- * the transmit field intelligible.
- */
-
-- *(u_int64_t *)(packet + NTP_TRANSMIT) = data->xmitck;
-+ *(uint64_t *)(packet + NTP_TRANSMIT) = data->xmitck;
-
- data->originate = current_time(JAN_1970);
-
-@@ -453,7 +454,7 @@ double
- current_time(double offset)
- {
- struct timeval current;
-- u_int64_t t;
-+ uint64_t t;
-
- if (gettimeofday(&current, NULL))
- err(1, "Could not get local time of day");
---- a/src/ntpleaps.c
-+++ b/src/ntpleaps.c
-@@ -45,12 +45,13 @@
- #include <fcntl.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#include <stdint.h>
- #include <string.h>
- #include <unistd.h>
-
- #include "ntpleaps.h"
-
--static u_int64_t *leapsecs;
-+static uint64_t *leapsecs;
- static unsigned int leapsecs_num;
-
-
-@@ -81,10 +82,10 @@ ntpleaps_init(void)
- }
-
- int
--ntpleaps_sub(u_int64_t *t)
-+ntpleaps_sub(uint64_t *t)
- {
- unsigned int i = 0;
-- u_int64_t u;
-+ uint64_t u;
- int r = 1;
-
- if (ntpleaps_init() == -1)
-@@ -105,10 +106,10 @@ ntpleaps_sub(u_int64_t *t)
- return (r);
- }
-
--u_int32_t
--read_be_dword(u_int8_t *ptr)
-+uint32_t
-+read_be_dword(uint8_t *ptr)
- {
-- u_int32_t res;
-+ uint32_t res;
-
- memcpy(&res, ptr, 4);
- return (ntohl(res));
-@@ -120,10 +121,10 @@ ntpleaps_read(void)
- {
- int fd;
- unsigned int r;
-- u_int8_t buf[32];
-- u_int32_t m1, m2, m3;
-- u_int64_t s;
-- u_int64_t *l;
-+ uint8_t buf[32];
-+ uint32_t m1, m2, m3;
-+ uint64_t s;
-+ uint64_t *l;
-
- fd = open("/usr/share/zoneinfo/right/UTC", O_RDONLY | O_NDELAY);
- if (fd == -1)
-@@ -153,7 +154,7 @@ ntpleaps_read(void)
- close(fd);
- return (-1);
- }
-- if ((l = (u_int64_t *)malloc(r << 3)) == NULL) {
-+ if ((l = (uint64_t *)malloc(r << 3)) == NULL) {
- close(fd);
- return (-1);
- }
---- a/src/ntpleaps.h
-+++ b/src/ntpleaps.h
-@@ -46,11 +46,13 @@
- #ifndef _NTPLEAPS_H
- #define _NTPLEAPS_H
-
-+#include <stdint.h>
-+
- /* Offset between struct timeval.tv_sec and a tai64_t */
- #define NTPLEAPS_OFFSET (4611686018427387914ULL)
-
- /* Hide this ugly value from programmes */
--#define SEC_TO_TAI64(s) (NTPLEAPS_OFFSET + (u_int64_t)(s))
-+#define SEC_TO_TAI64(s) (NTPLEAPS_OFFSET + (uint64_t)(s))
- #define TAI64_TO_SEC(t) ((t) - NTPLEAPS_OFFSET)
-
- /* Initializes the leap second table. Does not need to be called
-@@ -70,6 +72,6 @@ int ntpleaps_read(void);
- * to posix clock tick time.
- * returns 0 on success, -1 on error (time is unchanged), 1 on leap second
- */
--int ntpleaps_sub(u_int64_t *);
-+int ntpleaps_sub(uint64_t *);
-
- #endif
---- a/src/rfc868time.c
-+++ b/src/rfc868time.c
-@@ -50,6 +50,7 @@
- #include <stdio.h>
- #include <ctype.h>
- #include <err.h>
-+#include <stdint.h>
- #include <string.h>
- #include <netdb.h>
- #include <unistd.h>
-@@ -68,10 +69,10 @@ rfc868time_client (const char *hostname, int family, struct timeval *new,
- {
- struct addrinfo hints, *res0, *res;
- struct timeval old;
-- u_int32_t tim; /* RFC 868 states clearly this is an uint32 */
-+ uint32_t tim; /* RFC 868 states clearly this is an uint32 */
- int s;
- int error;
-- u_int64_t td;
-+ uint64_t td;
-
- memset(&hints, 0, sizeof(hints));
- hints.ai_family = family;
diff --git a/net-misc/rdate/files/rdate-1.10.2-respect-AR.patch b/net-misc/rdate/files/rdate-1.10.2-respect-AR.patch
deleted file mode 100644
index 05289f3453c9..000000000000
--- a/net-misc/rdate/files/rdate-1.10.2-respect-AR.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/resurrecting-open-source-projects/openrdate/pull/4
-
-From: Sam James <sam@gentoo.org>
-Date: Thu, 3 Feb 2022 09:30:53 +0000
-Subject: [PATCH] Respect AR from environment
-
-Detect `AR` from the environment (first the AR environment variable, but
-failing that, ${CHOST}-ar). This allows using different toolchains (e.g.
-Clang and LLVM's tooling) and also facilitates cross-compilation.
-
-Bug: https://bugs.gentoo.org/729998
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/configure.ac
-+++ b/configure.ac
-@@ -11,6 +11,8 @@ AC_CONFIG_SRCDIR([src/rdate.c])
- AC_CONFIG_HEADERS([config.h])
- AC_ARG_VAR([kernel_version], [the version of the kernel to build against])
-
-+AC_CANONICAL_HOST
-+
- # Checks for programs.
- AC_PROG_CC
-
-@@ -22,6 +24,8 @@ AC_PROG_INSTALL
- AC_PROG_RANLIB
- AC_PROG_EGREP
-
-+AM_PROG_AR
-+
- # Checks for libraries.
- AC_CHECK_LIB([c], [fork])
- AC_CHECK_LIB([util], [malloc])
-@@ -52,7 +56,6 @@ AC_CHECK_FUNCS([gettimeofday memset select socket])
- AC_PATH_PROG([UNAME], [uname],
- [:])
-
--AC_CANONICAL_HOST
- # Determine the particulars of the host
- case "${host}" in
- *-*-linux*)