summaryrefslogtreecommitdiff
path: root/net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild')
-rw-r--r--net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild b/net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild
new file mode 100644
index 000000000000..2360e41ade5b
--- /dev/null
+++ b/net-misc/selfdhcp/selfdhcp-0.2a-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small stealth network autoconfigure software"
+HOMEPAGE="http://selfdhcp.sourceforge.net"
+SRC_URI="mirror://sourceforge/selfdhcp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+
+DEPEND="
+ dev-libs/popt
+ dev-libs/libxml2:2=
+ >=net-libs/libnet-1.0.2:1.0
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-buffer-overflow.patch"
+)
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ dodoc AUTHORS ChangeLog README TODO
+}