summaryrefslogtreecommitdiff
path: root/net-misc/sntpd/sntpd-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 09:21:27 +0000
commit85ba3f2cfe9ff2b952efb1f3c3c08840f8093246 (patch)
treec8adb7f2695744136c00d176bd0ebd80677049aa /net-misc/sntpd/sntpd-3.1.ebuild
parentf9c971dedd369d9f45a38f3fae51467e864f5324 (diff)
gentoo auto-resync : 07:11:2022 - 09:21:27
Diffstat (limited to 'net-misc/sntpd/sntpd-3.1.ebuild')
-rw-r--r--net-misc/sntpd/sntpd-3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/sntpd/sntpd-3.1.ebuild b/net-misc/sntpd/sntpd-3.1.ebuild
new file mode 100644
index 000000000000..4d901ec1784a
--- /dev/null
+++ b/net-misc/sntpd/sntpd-3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="A NTP (RFC-1305 and RFC-4330) client and server for unix-alike systems"
+HOMEPAGE="https://github.com/troglobit/sntpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="adjtimex systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with adjtimex)
+ $(use_with systemd systemd $(systemd_get_systemunitdir))
+ --with-ntpclient
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/sntpd.initd-r1 sntpd
+ newconfd "${FILESDIR}"/sntpd.confd sntpd
+}