summaryrefslogtreecommitdiff
path: root/net-misc/spiped/spiped-1.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/spiped/spiped-1.6.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/spiped/spiped-1.6.0-r1.ebuild')
-rw-r--r--net-misc/spiped/spiped-1.6.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/spiped/spiped-1.6.0-r1.ebuild b/net-misc/spiped/spiped-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..b3ab508eb627
--- /dev/null
+++ b/net-misc/spiped/spiped-1.6.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="secure pipe daemon"
+HOMEPAGE="http://www.tarsnap.com/spiped.html"
+SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libressl"
+
+MY_PN="${PN/d/}"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+# Blocker added due to #548126
+RDEPEND="
+ ${DEPEND}
+ !net-mail/qlogtools"
+
+src_install() {
+ dobin "${MY_PN}/${MY_PN}"
+ dosbin "${PN}/${PN}"
+
+ doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ dodir "etc/${PN}"
+}
+
+pkg_postinst() {
+ elog
+ elog "You will need to configure spiped via its"
+ elog "configuration file located in /etc/conf.d/."
+ elog
+ elog "Please have a look at this file prior to starting up spiped!"
+ elog
+}