summaryrefslogtreecommitdiff
path: root/net-misc/spiped/spiped-1.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-misc/spiped/spiped-1.6.0-r1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-misc/spiped/spiped-1.6.0-r1.ebuild')
-rw-r--r--net-misc/spiped/spiped-1.6.0-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/net-misc/spiped/spiped-1.6.0-r1.ebuild b/net-misc/spiped/spiped-1.6.0-r1.ebuild
index b3ab508eb627..ca4826de3c19 100644
--- a/net-misc/spiped/spiped-1.6.0-r1.ebuild
+++ b/net-misc/spiped/spiped-1.6.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="secure pipe daemon"
HOMEPAGE="http://www.tarsnap.com/spiped.html"
SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
@@ -23,6 +25,14 @@ RDEPEND="
${DEPEND}
!net-mail/qlogtools"
+PATCHES=(
+ "${FILESDIR}/${P}-ldflags-support.patch"
+)
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
src_install() {
dobin "${MY_PN}/${MY_PN}"
dosbin "${PN}/${PN}"