summaryrefslogtreecommitdiff
path: root/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild')
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild b/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
new file mode 100644
index 000000000000..9bf1d84c1aca
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.10-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info multilib user
+
+DESCRIPTION="A client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="http://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE="static"
+
+RDEPEND=">=dev-libs/libevent-2.0.10
+ dev-libs/openssl:0
+ net-dialup/ppp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+DOCS=( AUTHORS ChangeLog DEVELOPERS INSTALL NEWS README TODO USING )
+
+pkg_setup() {
+ enewgroup sstpc
+ enewuser sstpc -1 -1 -1 sstpc
+}
+
+src_prepare() {
+ # set proper examples dir, --docdir overriding in src_configure does not work
+ sed -i -e "/^docdir/s:@PACKAGE@:${PF}/examples:" Makefile.am || die 'sed on Makefile.am failed'
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ PPPD_VER=${PPPD_VER#*/*-} # reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ econf \
+ --enable-ppp-plugin \
+ --enable-group=sstpc \
+ --enable-user=sstpc \
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}" \
+ --with-runtime-dir="/run/sstpc" \
+ $(use_enable static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}