summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 05:50:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 05:50:31 +0100
commit08b4047e14c989cfb931eff95973837f54ccc9e1 (patch)
tree8ef8443bb119630d0bdea4b374a58981490b6f0e /net-misc/streamlink/streamlink-9999.ebuild
parentc410d7a91a496a4fbbca686c80f7446305222d55 (diff)
gentoo auto-resync : 04:10:2023 - 05:50:30
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 9208c85c22e7..025dd94e32c9 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -9,7 +9,9 @@ if [[ ${PV} = 9999* ]]; then
fi
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
+# >= 6.2.1 uses a bunch of setuptools hooks instead of vanilla setuptools
+# https://github.com/streamlink/streamlink/commit/194d9bc193f5285bc1ba33af5fd89209a96ad3a7
+DISTUTILS_USE_PEP517=standalone
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE='xml(+),threads(+)'
inherit distutils-r1
@@ -19,7 +21,7 @@ HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="BSD-2 Apache-2.0"
@@ -47,6 +49,7 @@ RDEPEND="
"
BDEPEND="
$(python_gen_cond_dep '
+ >=dev-python/setuptools-64[${PYTHON_USEDEP}]
>=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]