summaryrefslogtreecommitdiff
path: root/net-misc/streamlink
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /net-misc/streamlink
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest2
-rw-r--r--net-misc/streamlink/streamlink-1.1.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 6503f250b622..a73493fc5abb 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,6 +1,8 @@
DIST streamlink-0.14.2.tar.gz 643695 BLAKE2B ea28daac32903738206226bce85a4615338b6039be1e4cce18325e977112c3301d6e6ed90d1210f4f362c898397fd980c136a98d8a0d5ff7ee2b6c5cf077f2c6 SHA512 0d9f1db32915392f9d29bcfb40743058352a924435a8ee77f1218c108e937204e88041c908d2f93546beaa70e18db62c961ea31fbdd85c5e7e4315a18118e276
DIST streamlink-1.0.0.tar.gz 674393 BLAKE2B 091272bae71f1e89cf14872578091a01f9d05ee372d4b9379e672280735c6800a33ae198bf019fbb3e970aa060ef059e5106e1be3a20602874be6206b6303bf6 SHA512 22ba96ac0ec27fe923b99898c45548df88ed3dda3bcbcb10b55fea145e20731eb8aa3a90212a5863b4ef5a7387d4bcf3d09d447ea2789762a8cf5eaa87f263d7
+DIST streamlink-1.1.1.tar.gz 681973 BLAKE2B a027074e7346ee1758f86456d0d3180bdb3cdbe9be7da232971fe6ece0d0723afa963bff67cef410757d85f7dc356f2a409ad3e84075c03328bbfa995fce796d SHA512 e493e7775eff84b7c70e60606296c71058b0c4ea25920ab6b2efa09cf45765c4b23287258729b60622e57594e7458a320e47301c1821b7211d49f366c73998cd
EBUILD streamlink-0.14.2-r1.ebuild 1866 BLAKE2B 758a98d241d23ae7cebc684b6c4bba32a299367d8bfd2da00303fda8801cc7de12cb29f8651c31f44e998f9acd6afdb4f1e030a909af373202ddf0971dc48667 SHA512 4bad5f11c62c873c446c65974a8c29cb91137fdab9fbe0ce7c29004d45d6780f11a8691603da1649b4b17d89da9ce172074d67e2313ebbfcbe932703c3ffe7cb
EBUILD streamlink-1.0.0.ebuild 2016 BLAKE2B 3df677b3d26216be7928269cca8b8d3b53d28ede18617e1ddce56874a405bde328e87c2168f09526a06160f8ff1f23f0109f166421bdb0e7299a4d06e2a40540 SHA512 977a6cf86917f9cd0025da1e39d8dd25b5870e88dcb8a6585caa70d8bdeaf102c24cd9b80d5aafcd1c21fc04f39358f9580a85838ebdfc5fdcebca01601bf1a2
+EBUILD streamlink-1.1.1.ebuild 2016 BLAKE2B 3df677b3d26216be7928269cca8b8d3b53d28ede18617e1ddce56874a405bde328e87c2168f09526a06160f8ff1f23f0109f166421bdb0e7299a4d06e2a40540 SHA512 977a6cf86917f9cd0025da1e39d8dd25b5870e88dcb8a6585caa70d8bdeaf102c24cd9b80d5aafcd1c21fc04f39358f9580a85838ebdfc5fdcebca01601bf1a2
EBUILD streamlink-9999.ebuild 1539 BLAKE2B 2609504dfce4ba218fcdcccc25618cd569d5f056e97d9c482d7132cc7dd226fb2a566372abe654aaaa33d698b88b527fa32ed98880f3b49a0807321648018837 SHA512 126ef095ca4affcca4bde3bb54070c9ce28b6371cfae1a28ea31986daed5a389bdeebf20a3392d7aca0e34f2355ef804ad9848711aa7ba4dfa84f67db4ebca29
MISC metadata.xml 330 BLAKE2B ad3caca1dc3dd2ea5915a6d14f9741ba7352d8a961939dacf89efdcae0cf1203343ca11ea230efc30cf69d359e09e7cd06218404943f8e4e3853a5c6676f7ff6 SHA512 73730cc94810711b86088a41beba0d0da4f20c4ca377c24122ebeac1ea68e712d03d0e79518df847aa15cb9d8a3f04658715f0b75dfaa1a6dfbedc0a15c33672
diff --git a/net-misc/streamlink/streamlink-1.1.1.ebuild b/net-misc/streamlink/streamlink-1.1.1.ebuild
new file mode 100644
index 000000000000..667a5f466f57
--- /dev/null
+++ b/net-misc/streamlink/streamlink-1.1.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+
+# >=urllib3-1.23 only needed for python2, but requests pulls some version anyways, so we might as well guarantee at least that ver for py3 too
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.23[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_which[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${RDEPEND}
+ media-video/rtmpdump
+ virtual/ffmpeg
+"
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
+
+python_compile_all() {
+ use doc && emake -C docs html man
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
+ distutils-r1_python_install_all
+}