summaryrefslogtreecommitdiff
path: root/net-misc/stuntman/stuntman-1.2.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /net-misc/stuntman/stuntman-1.2.15.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'net-misc/stuntman/stuntman-1.2.15.ebuild')
-rw-r--r--net-misc/stuntman/stuntman-1.2.15.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/stuntman/stuntman-1.2.15.ebuild b/net-misc/stuntman/stuntman-1.2.15.ebuild
new file mode 100644
index 000000000000..4801a72bba39
--- /dev/null
+++ b/net-misc/stuntman/stuntman-1.2.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Open source implementation of the STUN protocol"
+HOMEPAGE="http://www.stunprotocol.org"
+SRC_URI="http://www.stunprotocol.org/stunserver-${PV}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+S="${WORKDIR}/stunserver"
+
+src_compile() {
+ emake T=""
+}
+
+src_install() {
+ dobin stunclient
+ dosbin stunserver
+ dodoc HISTORY README
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+src_test() {
+ ./stuntestcode
+}