summaryrefslogtreecommitdiff
path: root/net-misc/taptap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /net-misc/taptap
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'net-misc/taptap')
-rw-r--r--net-misc/taptap/Manifest3
-rw-r--r--net-misc/taptap/files/taptap-1.0-missing-include.patch12
-rw-r--r--net-misc/taptap/taptap-1.0-r2.ebuild (renamed from net-misc/taptap/taptap-1.0-r1.ebuild)11
3 files changed, 20 insertions, 6 deletions
diff --git a/net-misc/taptap/Manifest b/net-misc/taptap/Manifest
index 252aaaab28aa..54a643b01e3c 100644
--- a/net-misc/taptap/Manifest
+++ b/net-misc/taptap/Manifest
@@ -1,3 +1,4 @@
+AUX taptap-1.0-missing-include.patch 252 BLAKE2B c598700530c2ddd80f6fc6ecdeb93ad488e13ab0cf1270122af1ee2265eab7b48e6a9954fece0968f082dfa68bcc18e8250583889725d63f0f271e0965618c1e SHA512 90466d4cb9a8a4ea0a721cbcc8efdbbcfd9bb8205f44d41052e1dffeecb1d2f2b0093eb62c265d2a81055c8850409ce2bf9cfd416dc14d70f632434fa00a1c5a
DIST taptap-1.0.c 2665 BLAKE2B 3c857770fd016c1837a3cdf6b8244965cd4128c9d260ab584ffa2e6e7e6deac4e35cb3800aec81f4950e0cd891bc7391be0a5a7b926681595ddde671d571d9bf SHA512 74ec6012cc34f5f4b5e2d16aff3840e842b7a7f297df5277b8ee7305fed900a16d25a853b8e9544b464037f9946ca1588959e5faafeff3afd14813ac419551e1
-EBUILD taptap-1.0-r1.ebuild 542 BLAKE2B f0a93313f04af6a39b6d0945ddbaab726431db7850caf3130a612f38a6db1a4ba0b19fb029d3c1f09ade51255e4c5966be0557ab918338d8e28dfb047881e3f4 SHA512 883a75b4249e073d509d5e017fccc0dc74c7b362dda39cae64cb4bc620a6c157fd5a4da4664f9e1e735dc608ca4fe03ca2a9581556b7551b0e9ccb4975a992ad
+EBUILD taptap-1.0-r2.ebuild 574 BLAKE2B da3d2c475f5e012c60e329056bb9bfbc80caa877086be23ca204d8c55028c0a6b1766aefa8bce8176db569675bb7d7153ef79abd9a6b23dbe501c651fa07da99 SHA512 4005320d82444eb6e0a9b2efdd5287a6577be374a224192c94735192ec3a22587a910a28217cc64a6058caee5c48f31aff226186af5ca4a39b1947200e896f78
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/net-misc/taptap/files/taptap-1.0-missing-include.patch b/net-misc/taptap/files/taptap-1.0-missing-include.patch
new file mode 100644
index 000000000000..9b8c37b574bb
--- /dev/null
+++ b/net-misc/taptap/files/taptap-1.0-missing-include.patch
@@ -0,0 +1,12 @@
+Add missing include
+https://bugs.gentoo.org/919058
+--- a/taptap.c
++++ b/taptap.c
+@@ -35,6 +35,7 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #ifndef __NetBSD__
+ #include <linux/if.h>
+ #include <linux/if_tun.h>
diff --git a/net-misc/taptap/taptap-1.0-r1.ebuild b/net-misc/taptap/taptap-1.0-r2.ebuild
index 5ea681d0e963..d0353dc3bfec 100644
--- a/net-misc/taptap/taptap-1.0-r1.ebuild
+++ b/net-misc/taptap/taptap-1.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit edo toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Program to link two /dev/net/tun to form virtual ethernet"
HOMEPAGE="https://grumpf.hope-2000.org/"
@@ -13,15 +13,16 @@ S="${WORKDIR}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
+PATCHES=( "${FILESDIR}/${P}-missing-include.patch" )
src_unpack() {
- cp "${DISTDIR}"/${P}.c ${P}.c || die
+ cp "${DISTDIR}/${P}.c" "${PN}.c" || die
}
src_compile() {
- edo $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${P}.c
+ emake CC="$(tc-getCC)" "${PN}"
}
src_install() {
- dobin ${PN}
+ dobin "${PN}"
}