summaryrefslogtreecommitdiff
path: root/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild')
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
index fe5bb78e69cc..9791ba1a3d47 100644
--- a/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
+++ b/net-misc/tcpsound/tcpsound-0.3.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+inherit toolchain-funcs
DESCRIPTION="Play sounds in response to network traffic"
LICENSE="BSD"
@@ -17,15 +17,17 @@ DEPEND="
net-analyzer/tcpdump
"
RDEPEND="${DEPEND}"
-
DOCS=( README.txt elaborate.conf )
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-misc.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-misc.patch
+)
src_compile() {
emake CC="$(tc-getCC)"
}
+
+src_install() {
+ default
+ gunzip $(find "${ED}" -name '*.[0-9].gz') || die
+}