summaryrefslogtreecommitdiff
path: root/net-misc/tigervnc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-misc/tigervnc/files
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-misc/tigervnc/files')
-rw-r--r--net-misc/tigervnc/files/tigervnc-1.12.0-disable-server-and-pam.patch57
-rw-r--r--net-misc/tigervnc/files/tigervnc-1.12.80-disable-server-and-pam.patch57
2 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/tigervnc/files/tigervnc-1.12.0-disable-server-and-pam.patch b/net-misc/tigervnc/files/tigervnc-1.12.0-disable-server-and-pam.patch
new file mode 100644
index 000000000000..5ae07007d467
--- /dev/null
+++ b/net-misc/tigervnc/files/tigervnc-1.12.0-disable-server-and-pam.patch
@@ -0,0 +1,57 @@
+See https://bugs.gentoo.org/852830
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -234,6 +234,7 @@
+ add_subdirectory(java)
+ endif()
+
++option(BUILD_SERVER "Build TigerVNC server" ON)
+ option(BUILD_VIEWER "Build TigerVNC viewer" ON)
+ if(BUILD_VIEWER)
+ # Check for FLTK
+@@ -276,7 +277,7 @@
+ endif()
+
+ # Check for PAM library
+-if(UNIX AND NOT APPLE)
++if(BUILD_SERVER AND UNIX AND NOT APPLE)
+ check_include_files(security/pam_appl.h HAVE_PAM_H)
+ set(CMAKE_REQUIRED_LIBRARIES -lpam)
+ check_function_exists(pam_start HAVE_PAM_START)
+@@ -315,9 +316,6 @@
+ add_subdirectory(media)
+ endif()
+
+-add_subdirectory(tests)
+-
+-
+ if(BUILD_VIEWER)
+ add_subdirectory(release)
+ endif()
+--- a/common/rfb/CMakeLists.txt
++++ b/common/rfb/CMakeLists.txt
+@@ -75,7 +75,7 @@
+
+ set(RFB_LIBRARIES ${JPEG_LIBRARIES} ${PIXMAN_LIBRARY} os rdr)
+
+-if(UNIX AND NOT APPLE)
++if(BUILD_SERVER AND UNIX AND NOT APPLE)
+ set(RFB_SOURCES ${RFB_SOURCES} UnixPasswordValidator.cxx
+ UnixPasswordValidator.h pam.c pam.h)
+ set(RFB_LIBRARIES ${RFB_LIBRARIES} ${PAM_LIBS})
+--- a/unix/CMakeLists.txt
++++ b/unix/CMakeLists.txt
+@@ -1,6 +1,8 @@
+ add_subdirectory(tx)
+ add_subdirectory(common)
+-add_subdirectory(vncconfig)
+-add_subdirectory(vncpasswd)
+-add_subdirectory(vncserver)
+-add_subdirectory(x0vncserver)
++if(BUILD_SERVER)
++ add_subdirectory(vncconfig)
++ add_subdirectory(vncpasswd)
++ add_subdirectory(vncserver)
++ add_subdirectory(x0vncserver)
++endif()
diff --git a/net-misc/tigervnc/files/tigervnc-1.12.80-disable-server-and-pam.patch b/net-misc/tigervnc/files/tigervnc-1.12.80-disable-server-and-pam.patch
new file mode 100644
index 000000000000..e61f099d397a
--- /dev/null
+++ b/net-misc/tigervnc/files/tigervnc-1.12.80-disable-server-and-pam.patch
@@ -0,0 +1,57 @@
+See https://bugs.gentoo.org/852830
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -234,6 +234,7 @@
+ add_subdirectory(java)
+ endif()
+
++option(BUILD_SERVER "Build TigerVNC server" ON)
+ option(BUILD_VIEWER "Build TigerVNC viewer" ON)
+ if(BUILD_VIEWER)
+ # Check for FLTK
+@@ -276,7 +277,7 @@
+ endif()
+
+ # Check for PAM library
+-if(UNIX AND NOT APPLE)
++if(BUILD_SERVER AND UNIX AND NOT APPLE)
+ check_include_files(security/pam_appl.h HAVE_PAM_H)
+ set(CMAKE_REQUIRED_LIBRARIES -lpam)
+ check_function_exists(pam_start HAVE_PAM_START)
+@@ -315,9 +316,6 @@
+ add_subdirectory(media)
+ endif()
+
+-add_subdirectory(tests)
+-
+-
+ if(BUILD_VIEWER)
+ add_subdirectory(release)
+ endif()
+--- a/common/rfb/CMakeLists.txt
++++ b/common/rfb/CMakeLists.txt
+@@ -88,7 +88,7 @@
+ target_sources(rfb PRIVATE WinPasswdValidator.cxx)
+ endif(WIN32)
+
+-if(UNIX AND NOT APPLE)
++if(BUILD_SERVER AND UNIX AND NOT APPLE)
+ target_sources(rfb PRIVATE UnixPasswordValidator.cxx pam.c)
+ target_link_libraries(rfb ${PAM_LIBS})
+ endif()
+--- a/unix/CMakeLists.txt
++++ b/unix/CMakeLists.txt
+@@ -1,6 +1,8 @@
+ add_subdirectory(tx)
+ add_subdirectory(common)
+-add_subdirectory(vncconfig)
+-add_subdirectory(vncpasswd)
+-add_subdirectory(vncserver)
+-add_subdirectory(x0vncserver)
++if(BUILD_SERVER)
++ add_subdirectory(vncconfig)
++ add_subdirectory(vncpasswd)
++ add_subdirectory(vncserver)
++ add_subdirectory(x0vncserver)
++endif()