summaryrefslogtreecommitdiff
path: root/net-misc/turbovnc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /net-misc/turbovnc/files
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'net-misc/turbovnc/files')
-rw-r--r--net-misc/turbovnc/files/turbovnc-2.2.7-fix-musl-compilation.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/turbovnc/files/turbovnc-2.2.7-fix-musl-compilation.patch b/net-misc/turbovnc/files/turbovnc-2.2.7-fix-musl-compilation.patch
new file mode 100644
index 000000000000..c9f5f0397b4c
--- /dev/null
+++ b/net-misc/turbovnc/files/turbovnc-2.2.7-fix-musl-compilation.patch
@@ -0,0 +1,51 @@
+See bug https://bugs.gentoo.org/836723
+
+There are 2 compilation errors:
+
+/var/tmp/portage/net-misc/turbovnc-2.2.7-r2/work/turbovnc-2.2.7/unix/Xvnc/programs/Xserver/os/access.c: In function 'GetLocalClientCreds':
+/var/tmp/portage/net-misc/turbovnc-2.2.7-r2/work/turbovnc-2.2.7/unix/Xvnc/programs/Xserver/os/access.c:1178:18: error: storage size of 'peercred' isn't known
+ 1178 | struct ucred peercred;
+ | ^~~~~~~~
+
+/var/tmp/portage/net-misc/turbovnc-2.2.7-r2/work/turbovnc-2.2.7/unix/Xvnc/programs/Xserver/Xext/xf86bigfont.c:48:10: fatal error: asm/page.h: No such file or directory
+ 48 | #include <asm/page.h>
+ | ^~~~~~~~~~~~
+
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -69,6 +69,8 @@
+ boolean_number(TVNC_BUILDSERVER)
+ report_option(TVNC_BUILDSERVER "TurboVNC Server")
+
++option(BUILDING_ON_MUSL "Define GNU macros on musl" 0)
++
+ if(TVNC_BUILDNATIVE OR TVNC_BUILDSERVER)
+ set(USEC 1)
+ endif()
+--- a/unix/Xvnc/programs/Xserver/os/CMakeLists.txt
++++ b/unix/Xvnc/programs/Xserver/os/CMakeLists.txt
+@@ -13,6 +13,10 @@
+ add_definitions(-DBSD44SOCKETS)
+ endif()
+
++if(BUILDING_ON_MUSL)
++ add_definitions(-D_GNU_SOURCE)
++endif()
++
+ set(EXTRASRCS "")
+ if(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
+ add_definitions(-DSECURE_RPC)
+--- a/unix/Xvnc/programs/Xserver/Xext/CMakeLists.txt
++++ b/unix/Xvnc/programs/Xserver/Xext/CMakeLists.txt
+@@ -8,6 +8,10 @@
+ endif()
+ endforeach()
+
++if(BUILDING_ON_MUSL)
++ add_definitions(-D__GNU_LIBRARY__=2)
++endif()
++
+ disable_compiler_warnings()
+ handle_type_puns()
+