summaryrefslogtreecommitdiff
path: root/net-misc/vde/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 01:09:44 +0000
commite33383d972aad8129fd4c1ee2b87f529f6efa8e9 (patch)
tree6a41fd6c2b9a997737264687637da3a9eee3d9d6 /net-misc/vde/files
parent89aeb05c8da1b0c32fb9d0cd5d202763780d5d5a (diff)
gentoo auto-resync : 24:11:2022 - 01:09:44
Diffstat (limited to 'net-misc/vde/files')
-rw-r--r--net-misc/vde/files/vde-2.3.2-fix-inline-funcs-r1.patch21
-rw-r--r--net-misc/vde/files/vde-2.3.2-format-security.patch18
-rw-r--r--net-misc/vde/files/vde-2.3.2-openssl-1.1.patch104
-rw-r--r--net-misc/vde/files/vde-2.3.2-slibtool-support.patch49
4 files changed, 0 insertions, 192 deletions
diff --git a/net-misc/vde/files/vde-2.3.2-fix-inline-funcs-r1.patch b/net-misc/vde/files/vde-2.3.2-fix-inline-funcs-r1.patch
deleted file mode 100644
index c1329d0f7207..000000000000
--- a/net-misc/vde/files/vde-2.3.2-fix-inline-funcs-r1.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-# Sourced from https://raw.githubusercontent.com/OpenMandrivaAssociation/vde2/master/vd2-2.3.2-clang.patch
-
---- a/src/vde_switch/fstp.c 2014-10-29 22:54:18.659988435 +0000
-+++ b/src/vde_switch/fstp.c 2014-10-29 22:54:44.912986501 +0000
-@@ -30,14 +30,14 @@
- #ifdef FSTP
- #include <fstp.h>
- /*********************** sending macro used by FSTP & Core ******************/
--void inline ltonstring(unsigned long l,unsigned char *s) {
-+void ltonstring(unsigned long l,unsigned char *s) {
- s[3]=l; l>>=8;
- s[2]=l; l>>=8;
- s[1]=l; l>>=8;
- s[0]=l;
- }
-
--unsigned long inline nstringtol(unsigned char *s) {
-+unsigned long nstringtol(unsigned char *s) {
- return (s[0]<<24)+(s[1]<<16)+(s[2]<<8)+s[3];
- }
-
diff --git a/net-misc/vde/files/vde-2.3.2-format-security.patch b/net-misc/vde/files/vde-2.3.2-format-security.patch
deleted file mode 100644
index d1cfaa58cb2f..000000000000
--- a/net-misc/vde/files/vde-2.3.2-format-security.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/src/common/cmdparse.c 2017-09-20 18:47:31.662856695 -0400
-+++ b/src/common/cmdparse.c 2017-09-20 18:48:54.008852141 -0400
-@@ -284,13 +284,13 @@
- int i;
- for (i=0;i<argc;i++) {
- if (i) fprintf(mf," ");
-- fprintf(mf,argv[i]);
-+ fprintf(mf,"%s",argv[i]);
- }
- } else {
- int num=atoi(t);
- while (*t >='0' && *t <= '9') t++;
- if (num < argc)
-- fprintf(mf,argv[num]);
-+ fprintf(mf,"%s",argv[num]);
- }
- } else
- fprintf(mf,"%c",*t);
diff --git a/net-misc/vde/files/vde-2.3.2-openssl-1.1.patch b/net-misc/vde/files/vde-2.3.2-openssl-1.1.patch
deleted file mode 100644
index b490b93350f4..000000000000
--- a/net-misc/vde/files/vde-2.3.2-openssl-1.1.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-From 5f2c4c7b67617991af65798a4d177ada90f7e463 Mon Sep 17 00:00:00 2001
-From: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
-Date: Fri, 2 Sep 2016 19:52:49 +0000
-Subject: [PATCH] vde_cryptcab: compile against openssl 1.1.0
-
-Signed-off-by: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
----
- src/vde_cryptcab/cryptcab.c | 30 +++++++++++++++++++-----------
- 1 file changed, 19 insertions(+), 11 deletions(-)
-
-diff --git a/src/vde_cryptcab/cryptcab.c b/src/vde_cryptcab/cryptcab.c
-index c5b4474..a2780f1 100644
---- a/src/vde_cryptcab/cryptcab.c 2011-11-23 16:41:17.000000000 +0000
-+++ b/src/vde_cryptcab/cryptcab.c 2017-03-20 22:54:20.452975075 +0000
-@@ -22,7 +22,7 @@
- exit(1);
- }
-
--static EVP_CIPHER_CTX ctx;
-+static EVP_CIPHER_CTX *ctx;
- static int ctx_initialized = 0;
- static int encryption_disabled = 0;
- static int nfd;
-@@ -30,6 +30,10 @@
- static struct vde_open_args open_args={.port=0,.group=NULL,.mode=0700};
- static int verbose = 0;
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000
-+#define EVP_CIPHER_CTX_reset(x) EVP_CIPHER_CTX_cleanup(x)
-+#endif
-+
- void vc_printlog(int priority, const char *format, ...)
- {
- va_list arg;
-@@ -103,19 +107,21 @@
- }
-
- if (!ctx_initialized) {
-- EVP_CIPHER_CTX_init (&ctx);
-+ ctx = EVP_CIPHER_CTX_new ();
-+ if (!ctx)
-+ return -1;
- ctx_initialized = 1;
- }
-
-- EVP_EncryptInit (&ctx, EVP_bf_cbc (), p->key, p->iv);
-- if (EVP_EncryptUpdate (&ctx, dst, &olen, src, len) != 1)
-+ EVP_EncryptInit (ctx, EVP_bf_cbc (), p->key, p->iv);
-+ if (EVP_EncryptUpdate (ctx, dst, &olen, src, len) != 1)
- {
- fprintf (stderr,"error in encrypt update\n");
- olen = -1;
- goto cleanup;
- }
-
-- if (EVP_EncryptFinal (&ctx, dst + olen, &tlen) != 1)
-+ if (EVP_EncryptFinal (ctx, dst + olen, &tlen) != 1)
- {
- fprintf (stderr,"error in encrypt final\n");
- olen = -1;
-@@ -124,7 +130,7 @@
- olen += tlen;
-
- cleanup:
-- EVP_CIPHER_CTX_cleanup(&ctx);
-+ EVP_CIPHER_CTX_reset(ctx);
- return olen;
- }
-
-@@ -138,19 +144,21 @@
- }
-
- if (!ctx_initialized) {
-- EVP_CIPHER_CTX_init (&ctx);
-+ ctx = EVP_CIPHER_CTX_new ();
-+ if (!ctx)
-+ return -1;
- ctx_initialized = 1;
- }
-
-- EVP_DecryptInit (&ctx, EVP_bf_cbc (), p->key, p->iv);
-- if (EVP_DecryptUpdate (&ctx, dst, &olen, src, len) != 1)
-+ EVP_DecryptInit (ctx, EVP_bf_cbc (), p->key, p->iv);
-+ if (EVP_DecryptUpdate (ctx, dst, &olen, src, len) != 1)
- {
- fprintf (stderr,"error in decrypt update\n");
- olen = -1;
- goto cleanup;
- }
-
-- if (EVP_DecryptFinal (&ctx, dst + olen, &tlen) != 1)
-+ if (EVP_DecryptFinal (ctx, dst + olen, &tlen) != 1)
- {
- fprintf (stderr,"error in decrypt final\n");
- olen = -1;
-@@ -159,7 +167,7 @@
- olen += tlen;
-
- cleanup:
-- EVP_CIPHER_CTX_cleanup(&ctx);
-+ EVP_CIPHER_CTX_reset (ctx);
- return olen;
- }
-
diff --git a/net-misc/vde/files/vde-2.3.2-slibtool-support.patch b/net-misc/vde/files/vde-2.3.2-slibtool-support.patch
deleted file mode 100644
index 5eeb3a5c9026..000000000000
--- a/net-misc/vde/files/vde-2.3.2-slibtool-support.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From d11d9dd8b370016a2d10ffd35c450c9f68e578a5 Mon Sep 17 00:00:00 2001
-From: orbea <orbea@riseup.net>
-Date: Wed, 17 Mar 2021 15:14:45 -0700
-Subject: [PATCH] build: Only use -module for libraries.
-
----
- src/vde_l3/Makefile.am | 9 +++++++--
- src/vde_router/Makefile.am | 2 +-
- 2 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/vde_l3/Makefile.am b/src/vde_l3/Makefile.am
-index 748cb78..855081c 100644
---- a/src/vde_l3/Makefile.am
-+++ b/src/vde_l3/Makefile.am
-@@ -1,7 +1,6 @@
--
- moddir = $(pkglibdir)/vde_l3
-
--AM_LDFLAGS = -module -avoid-version -export-dynamic
-+AM_LDFLAGS = -avoid-version -export-dynamic
- AM_LIBTOOLFLAGS = --tag=disable-static
- AM_CPPFLAGS = -I$(top_srcdir)/include
-
-@@ -15,6 +14,12 @@ pfifo_la_SOURCES = pfifo.c vde_buff.h
- tbf_la_SOURCES = tbf.c vde_buff.h
- bfifo_la_SOURCES = bfifo.c vde_buff.h
-
-+vde_l3_lib_LDFLAGS = -module
-+
-+pfifo_la_LDFLAGS = $(vde_l3_lib_LDFLAGS)
-+bfifo_la_LDFLAGS = $(vde_l3_lib_LDFLAGS)
-+tbf_la_LDFLAGS = $(vde_l3_lib_LDFLAGS)
-+
- pfifo_la_LIBADD = $(top_builddir)/src/common/libvdecommon.la
- bfifo_la_LIBADD = $(top_builddir)/src/common/libvdecommon.la
- tbf_la_LIBADD = $(top_builddir)/src/common/libvdecommon.la
-diff --git a/src/vde_router/Makefile.am b/src/vde_router/Makefile.am
-index d872388..d055259 100644
---- a/src/vde_router/Makefile.am
-+++ b/src/vde_router/Makefile.am
-@@ -1,7 +1,7 @@
-
- moddir = $(pkglibdir)/vde_router
-
--AM_LDFLAGS = -module -avoid-version -export-dynamic
-+AM_LDFLAGS = -avoid-version -export-dynamic
- AM_LIBTOOLFLAGS = --tag=disable-static
- AM_CPPFLAGS = -I$(top_srcdir)/include
-