summaryrefslogtreecommitdiff
path: root/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild')
-rw-r--r--net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild38
1 files changed, 28 insertions, 10 deletions
diff --git a/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
index 221b1344f245..91d250b58b94 100644
--- a/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
+++ b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A command-line tool for taking JPEG snapshots of VNC servers"
HOMEPAGE="http://vncsnapshot.sourceforge.net/"
@@ -12,32 +12,50 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
DEPEND="
+ sys-libs/zlib
virtual/jpeg
- >=sys-libs/zlib-1.1.4"
+"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-amd64grey.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-amd64grey.patch"
+ default
+
sed \
-e 's:-I/usr/local/include::g' \
-e 's:-L/usr/local/lib::g' \
-e '/^all:/s|$(SUBDIRS:.dir=.all)||g' \
-e '/^vnc/s|$| $(SUBDIRS:.dir=.all)|g' \
-i Makefile || die
+
+ # Preserve make instance
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+
+ # Respect RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' rdr/Makefile || die
}
src_compile() {
- #note: We override CDEBUGFLAGS instead of CFLAGS because otherwise
- # we lost the INCLUDES in the makefile.
+ # We override CDEBUGFLAGS instead of CFLAGS because otherwise
+ # we lose the INCLUDES in the makefile. The same flags are used
+ # for both.
# bug #295741
- emake CDEBUGFLAGS="${CXXFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+ local args=(
+ AR="$(tc-getAR)"
+ CDEBUGFLAGS="${CXXFLAGS}"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ RANLIB="$(tc-getRANLIB)"
+ )
+ emake "${args[@]}"
}
src_install() {
dobin vncsnapshot
- cp vncsnapshot.man1 vncsnapshot.1
- doman vncsnapshot.1
+ newman vncsnapshot.man1 vncsnapshot.1
}