summaryrefslogtreecommitdiff
path: root/net-misc/whatportis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/whatportis
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/whatportis')
-rw-r--r--net-misc/whatportis/Manifest4
-rw-r--r--net-misc/whatportis/metadata.xml13
-rw-r--r--net-misc/whatportis/whatportis-0.6.ebuild34
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/whatportis/Manifest b/net-misc/whatportis/Manifest
new file mode 100644
index 000000000000..6da1096dcfb6
--- /dev/null
+++ b/net-misc/whatportis/Manifest
@@ -0,0 +1,4 @@
+DIST whatportis-0.6.tar.gz 218447 SHA256 d037a5b36629b0775527dea71a95feb99a5e619cca7626abe52edf6590c13602 SHA512 f9a46974618b0c70164de29aa9c57c7d0cb3c0a09626ec3d7d514fe0b88ce50b2acca1f9e949449508a2b170311e470fe9c7f3ed66f0af4ef01fd63dd815b8a2 WHIRLPOOL d02cfa19af5e7cd759bab614b6b10facc17c6f71e2588369ae2864da6706a2c2b2b1c2695eab312023533aa9751e82f5e9f82e99aea1cacde0df29e7339a98af
+EBUILD whatportis-0.6.ebuild 851 SHA256 95b727a4ac48c1a7b0973399e7d3b60ecd9571ff63cab87936691cbb30677b66 SHA512 fb4c3f4b52ca3abc67d42a98d2bfa717f93dd35105d9d15f3703737429868e85fb00bf5c3a5b3324e0985a71e2d3f72572968fdea8a809fbeb96826ac9a980f3 WHIRLPOOL 2bd33362ecc79bb5f01848622bde263db6320618c24d6b04c8811b231d34307369e5f0d6103a8828c2b6374c867ff00a171d6fbd3f0d270c8120703064c585f1
+MISC ChangeLog 2759 SHA256 abd94eb40d3b38478f3ac6b8f2b1903d1547ed56938b536d0f96cae810732fdb SHA512 77da2fd08565d02a88a70a8ed28dfeeebd2e2f67e77e880ab732d7809d99f9fcf317d6de6a81a9d15da61d015aabe6d8b5ca1bcfb75c346a6b6c1d7b5e3e8f9e WHIRLPOOL b323793aa7578d642bef7b9928af4acda83d70382c762d2aa69f506509f7aad909a70cb3868a8d7edcc4f284593a09e702923c6e8515ca15f87768afb6533dc8
+MISC metadata.xml 433 SHA256 07ebcb9e94bd5c726487a44245698ce42d796e40045d939e12fa6e8f9a504946 SHA512 07dcab4d60662404545f0a48a9a70cbda5791adff2bfad29a8877fcaa78a91b117edd750d11779ccfb04ba5332b0cc8b97482d368976b2e926e0076bd1fe783d WHIRLPOOL 685464f6691b682d924126ae20e5cfbfcb87ad3422b984d8d9c50608a0a536b950db5041e37e5f9f5e0182bb89e8e96dd35e6c9a3842bd2ae5fb00ff24c0a846
diff --git a/net-misc/whatportis/metadata.xml b/net-misc/whatportis/metadata.xml
new file mode 100644
index 000000000000..497425e26622
--- /dev/null
+++ b/net-misc/whatportis/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="pypi">whatportis</remote-id>
+ <maintainer status="unknown">
+ <email>ncrocfer@gmail.com</email>
+ <name>Nicolas Crocfer</name>
+ </maintainer>
+ <remote-id type="github">ncrocfer/whatportis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/whatportis/whatportis-0.6.ebuild b/net-misc/whatportis/whatportis-0.6.ebuild
new file mode 100644
index 000000000000..97cd47b75bf4
--- /dev/null
+++ b/net-misc/whatportis/whatportis-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A command to search port names and numbers"
+HOMEPAGE="https://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/click-6.2[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/tinydb-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.8.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test_${PN}.py || die
+}
+
+pkg_postinst() {
+ optfeature "Run ${PN} as a Server" dev-python/flask
+}