summaryrefslogtreecommitdiff
path: root/net-misc/yangcli-pro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/yangcli-pro
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/yangcli-pro')
-rw-r--r--net-misc/yangcli-pro/Manifest3
-rw-r--r--net-misc/yangcli-pro/metadata.xml8
-rw-r--r--net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/yangcli-pro/Manifest b/net-misc/yangcli-pro/Manifest
new file mode 100644
index 000000000000..8aa6c4ddee80
--- /dev/null
+++ b/net-misc/yangcli-pro/Manifest
@@ -0,0 +1,3 @@
+DIST yangcli-pro-16.10-8.deb8.amd64.deb 1406108 SHA256 4c69d5fd9c99272a8bb1074cdf3bc9de616866bb078546c214df86eefaa8bc10 SHA512 23db68a22d83a95638f1c155126118290fba38fd1bca524d29c75f227a14b15f20982c47b598c235b4e78e905090c17b242a27d59350cbcd9b4179da070d74c6 WHIRLPOOL a941936193e07f450a866692c5c153f9d67e309728fdf4a47bb27f2ce0a67d5069facb286e2af99700ff5920861aa3275a2b8ccbbf9b812b3e424ea41317b037
+EBUILD yangcli-pro-16.10_p8.ebuild 1081 SHA256 8877dae706060f37ff1b61010c542c1b94db44a4fa4bdd4b4206c0c119bec11e SHA512 964b064f542b89997987460e9f6aadd1c5957debec88a3f050eb14c86af245406e224b71d7fad40520dd6ac766ebc5592b08efd956c037f2aa48ec9136812932 WHIRLPOOL 905dbdce11f3bcf9d9d4e401c98fe652d4e16c68029011064affb018069393dc2f25e2d7f7df0037f2b87e96b2b4d938b44e73c97abb999af10c16aad751b976
+MISC metadata.xml 251 SHA256 f6ff468128d9aa804b47d9a184c761b4123b908d302eec0953226acd00fc80df SHA512 7ea734b9e52a4e36b11e004da4a8178aa529574adee2129ba57b1ce75fd5017431fdfffe7a4a536c798ae645497a44b07c748d77308325cf4d6af070ff167edd WHIRLPOOL 1610f6ab9cfa21736bbc4643fec692b621f8889a5888b4189847af4aa6f5719829cfaba363c480483fe7e8fb2c40d417e986964b52cb21d564940c4b51f8554d
diff --git a/net-misc/yangcli-pro/metadata.xml b/net-misc/yangcli-pro/metadata.xml
new file mode 100644
index 000000000000..5087760546f6
--- /dev/null
+++ b/net-misc/yangcli-pro/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild b/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild
new file mode 100644
index 000000000000..e4181608fce5
--- /dev/null
+++ b/net-misc/yangcli-pro/yangcli-pro-16.10_p8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit unpacker
+
+RESTRICT="bindist mirror strip"
+MY_PV=${PV/_p/-}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}
+
+DESCRIPTION="Network manager client that lets you test and manage NETCONF servers"
+HOMEPAGE="https://www.yumaworks.com/yangcli-pro/"
+SRC_URI="amd64? ( https://www.yumaworks.com/pub/${PN}/${MY_PV}/deb8/${MY_P}.deb8.amd64.deb )"
+
+LICENSE="yangcli-pro"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE=""
+
+RDEPEND="net-libs/libssh2
+ sys-libs/ncurses:5/5[tinfo]"
+
+src_install() {
+ dodoc usr/share/doc/yangcli-pro/changelog.gz
+ dodoc usr/share/doc/yumapro/*.pdf
+ dodoc usr/share/doc/yumapro/README
+ dobin usr/bin/yangcli-pro
+ dolib usr/lib/libyumapro_{ncx,mgr,ycli}.so{,.16.10}
+ doman usr/share/man/man1/yangcli-pro.1.gz
+ local my_module
+ for my_module in ietf/{RFC,DRAFT} netconfcentral yumaworks ; do
+ insinto /usr/share/yumapro/modules/${my_module}
+ doins usr/share/yumapro/modules/${my_module}/*.yang
+ done
+ insinto /etc/yumapro
+ doins etc/yumapro/yangcli-pro-sample.conf
+}