summaryrefslogtreecommitdiff
path: root/net-misc/youtube-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-misc/youtube-dl
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest2
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.11.05.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 090d4767851e..4065338322d6 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,4 +1,6 @@
DIST youtube-dl-2019.10.29.tar.gz 3172150 BLAKE2B 2cdaed88f1518245515d3d4030db8dd22b83ad1955bbd08fcef52b581d35f2de28dd9a95aafaede4edcba67aaf3b6e7697142ed6c715754da957a5cf8476cf80 SHA512 53d79440a86a08c39ec2f6d26e54aec12594b41419aeba2494eab087b49de97485beaeabc17cf819024799cf6f44d2386422c9d8f484c091c34b8cb202023c9d
+DIST youtube-dl-2019.11.05.tar.gz 3159084 BLAKE2B 9db643c3f3fafa0ee0b35b24afa411a169fe91f4dc2dd756ce1d3ce4b0db32cb483bca9cafdde6395232f38d5bafe90cca065fe7c1359f35d26e75dfecdb8bc3 SHA512 ec6d42e61d01e7f4087e980953c47facbbc9c5722d40f6c066789b940e084042fdc9a00266c13822a671137adf7f528fd7eb31a7849337e2e7418a722d9f865f
EBUILD youtube-dl-2019.10.29.ebuild 2124 BLAKE2B 608cd130bf27ff5253236fea27c22981fd804fa73e49ee6d0e67173d1840bd266349334f041307b4fe82c7a0708ae1a032d8f3d113dda7e0931197267f4b1246 SHA512 7ff84adcc79769d2acd9f9baa88e6f4222c65e8c892de335200e0f27d2aa15dc839241363bd2f58a6fe37e0af1345b072c5147a2205a927caeb9b9540dc17f72
+EBUILD youtube-dl-2019.11.05.ebuild 2130 BLAKE2B a6b9c8c31b6c7631f19183fccd1adf7b4c3ae5f5bc3108549803c83df78b66c2af9e04e1549a70b6f3bcca4cbc78a6e279f8aa063259c63e2fa464996ee69bcd SHA512 84f330ea104602ecd898906b7d33c98bd254715fc9feb5e71d35e34ac32466b56f178d22fe72dbea83f78ba45ffcd5fe73952c6d508dfc99bccec9a237daa155
EBUILD youtube-dl-99999999.ebuild 1997 BLAKE2B 7b5974dc4df22cbb2fb7d87f60e73b2fddc7117331a6a81e8e9f0efef84788211d5fdefb1c96e9d4df0677fda2d264ef2846f36e60a890233fa79b06722b2abb SHA512 71019b536d5301dfbd5e9cb8085d1a001854f5bf204c0e76866c16a9553516a55081c17396bcc89c0128e44116b6e2dc451541b7e89d677822f3d541b316d5c5
MISC metadata.xml 218 BLAKE2B 717fcfd86a1f75e0ad21845c9b496cf01d7bc7c80b6be8c08143ea304a08fbb75352e82e8fc883398e96da9c037f8912c4a9612b5cf85ffb25b3a5f041b02fe2 SHA512 d36d668a636222ce6394eca2598850e68139819543fd3cf0e76301e2a61c9b9303026b49536d1ed1b52f44d5703dc5e4247df786e0b4a704b28872e0a4a71b27
diff --git a/net-misc/youtube-dl/youtube-dl-2019.11.05.ebuild b/net-misc/youtube-dl/youtube-dl-2019.11.05.ebuild
new file mode 100644
index 000000000000..89ac8f636eea
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.11.05.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}