summaryrefslogtreecommitdiff
path: root/net-misc/youtube-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /net-misc/youtube-dl
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest2
-rw-r--r--net-misc/youtube-dl/youtube-dl-2019.06.08.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index aebf31ebf105..77417613325c 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,4 +1,6 @@
DIST youtube-dl-2019.05.20.tar.gz 3167834 BLAKE2B fe5501380b5134665b3c5c31a7b703832d7c7d9675c1e7c20bfa2b4ebc175e37521b423b68d3701a3637e047e3d4f12e54786f7d6f23e896f0a9da93c39be6f5 SHA512 c50661585f987a6c2abc7b9940749a2ba8e9a534d66f0846dddb265be3fe5a58ba8009fbad44c2551c7574b73bc21aa35f7d633729c0090c46e5818199dccb1d
+DIST youtube-dl-2019.06.08.tar.gz 3169571 BLAKE2B 4603e19e80921b12526575bd13a0b43ff98d871e7a40415dd5b09bb2a0b720ffd60f4d54eecbf44b7144146a6f64d9692a1aaa42c06e4944f5a5a00667c411c3 SHA512 6758d629ff0b56ed6589d024f29761cbe4678154316a370090d6eca62611791b79b8662a70c54e333362db0495131935d47bcbfcb40ae6dcf1cc0c8808790799
EBUILD youtube-dl-2019.05.20.ebuild 2119 BLAKE2B 82163aa22bf146600523fbb31e67d22af5a7a591e6b0c3900ca992f89fb45ec4536000872934b8a2d3beeb0a2d25ead1e8a500878c4db5dc70611d7609e00a0f SHA512 93ba6d18d95c861af5a8224e7ca8ee9947198e3e0b3a66e0bb70e5beb12a2b0bdbd004c5f619a97e6b30985ef3581ebaf163ca69a2dc1d2345de0ebb3c01f81c
+EBUILD youtube-dl-2019.06.08.ebuild 2125 BLAKE2B 50e06196444aee277e8bc2a72c762b76b7de6a9616f3ec6ccd76cfff696c4fcbb6e2c64022fcd5536708441a9009fb06b424fd7cbd86b7a58cee8108f908c6f0 SHA512 ee93e8557d67c11a7ead1bc1f0fefaec1f331aeea30a2fe93efd913d5a866380b62ba8a02d1115fb257d1989818a06eeea4e00d9acc35fe8feee147b8d6ed5b5
EBUILD youtube-dl-99999999.ebuild 2014 BLAKE2B 55abeec62089210469af6edf2cde4f8764eb1a5d20a3cd96985dce8a833023e5dd2e44cc893a7db99d9002fc671601fabd1c26cdbfa0fc0411a9ba11e1715b78 SHA512 bbbfb4e6e8319e383eaf4db4dd4056f34374eb6f1527c6cc1c6ee0d9f61199a913bc99f929bd91ef80aa744ba9a865833395460d8b94125c362c59372f738346
MISC metadata.xml 218 BLAKE2B 717fcfd86a1f75e0ad21845c9b496cf01d7bc7c80b6be8c08143ea304a08fbb75352e82e8fc883398e96da9c037f8912c4a9612b5cf85ffb25b3a5f041b02fe2 SHA512 d36d668a636222ce6394eca2598850e68139819543fd3cf0e76301e2a61c9b9303026b49536d1ed1b52f44d5703dc5e4247df786e0b4a704b28872e0a4a71b27
diff --git a/net-misc/youtube-dl/youtube-dl-2019.06.08.ebuild b/net-misc/youtube-dl/youtube-dl-2019.06.08.ebuild
new file mode 100644
index 000000000000..a8b1afbfc11a
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2019.06.08.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+LICENSE="public-domain"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+RESTRICT="test"
+SLOT="0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins ${PN}.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
+ elog
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need avconf (media-video/libav) or"
+ elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
+ elog "videos can be retrieved in a higher quality format without sound."
+ elog "${PN} will detect whether avconv/ffmpeg is present and"
+ elog "automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want ${PN} to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}