summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild')
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild b/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
new file mode 100644
index 000000000000..4c0bfc7cd619
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2021.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~riscv ~x86"
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ media-video/ffmpeg
+
+"
+
+distutils_enable_tests nose
+
+python_test() {
+ # make_lazy_extractors.py tries to rename it out, so fails if it does not exists.
+ mkdir ytdlp_plugins
+ epytest -k 'not download'
+}
+
+python_install_all() {
+ doman yt-dlp.1
+
+ newbashcomp completions/bash/yt-dlp yt-dlp
+
+ insinto /usr/share/zsh/site-functions
+ newins completions/zsh/_yt-dlp _yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ distutils-r1_python_install_all
+
+ rm -rf "${ED}"/usr/share/doc/yt_dlp || die
+}