summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-24 06:30:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-24 06:30:58 +0000
commit17e417b73cb3e25edbc6541bd107bc9c593d66bd (patch)
tree866f98b73f846149d0c9e7e5a1cf0527b7c54e08 /net-misc/yt-dlp
parent338095605b6c9c82690f77f27a32490c9a57bdcb (diff)
gentoo auto-resync : 24:12:2024 - 06:30:57
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.12.23.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index bff836bb39ff..e54f5f422553 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2024.12.13.tar.gz 5813833 BLAKE2B ead14c4922e74e75dcdabe63ed5bb4a91e7d30a3b475acad63c03320a5958190118a886c88a7f5424ed6b7cbb9115c2368b41737b1ad99165f925c3f6a38275b SHA512 369cb303a4bf14b8e872ea3315478c943bc13741eaa4ee1d219df0d5e89d1c46992577acb8530c592e4278da1af7969a25417972c2ca55d84ee0f8e7e25c31b4
+DIST yt-dlp-2024.12.23.tar.gz 5817118 BLAKE2B 99df0c13661d5768bb38545d59ba982365ca62a26c90f7217793b9a386ad932164e4e166c20cb05449cf56950324a56ee3aea56a2fb1fa5258dc8e0872e2e784 SHA512 8b068ebb88fc7339f685dfe999a1814f43098c16bd89033154f872e53e6743090c210ac5cb5cdd783ebd947ac33ecb749b08bbec9c7d7dc41da3424968666ee8
EBUILD yt-dlp-2024.12.13.ebuild 2177 BLAKE2B 5a7c49c8b9c8929ca34cf4e1f271735d0f84f9d860157e3ee6b9c8af0fd7a15b7657a05c0dc79f680f146ed171577f4714ff82708e7134c0848d717722960a4e SHA512 276d7684b50801919ab4b66b169148f65174e1d630e632d4ea7410fecdf0ccff575826e1feb0e4c55d6e8abe934a77f6ccc643a882a577cc0187f438c3c2e404
+EBUILD yt-dlp-2024.12.23.ebuild 2177 BLAKE2B 5a7c49c8b9c8929ca34cf4e1f271735d0f84f9d860157e3ee6b9c8af0fd7a15b7657a05c0dc79f680f146ed171577f4714ff82708e7134c0848d717722960a4e SHA512 276d7684b50801919ab4b66b169148f65174e1d630e632d4ea7410fecdf0ccff575826e1feb0e4c55d6e8abe934a77f6ccc643a882a577cc0187f438c3c2e404
EBUILD yt-dlp-9999.ebuild 2197 BLAKE2B 61f5b720a56c7d82289c8a056146410d4817137e3085215c913a6f765853ac7989587fb98fdcbd52fe2e729137f53a8923f0732ad59522954170102049dac973 SHA512 29f9b741292ddf8333a062827265e589f98d2b2f040b83458f6937846e3f070e577d2aeddca69684182cc176d1ef793e3fd287856ea2164007e6fb639eea209e
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2024.12.23.ebuild b/net-misc/yt-dlp/yt-dlp-2024.12.23.ebuild
new file mode 100644
index 000000000000..3de67e0bfb4a
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.12.23.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}
+
+LICENSE="Unlicense"
+SLOT="0"
+# note that yt-dlp bumps are typically done straight-to-stable (unless there
+# was major/breaking changes) given website changes breaks it on a whim
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}