summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
commit517343fddd94e620e94be97ae22eca4b57dc7625 (patch)
tree70b62f663c2d6f154c8808e55e827c69509918bd /net-misc/yt-dlp
parent6554f04b9a44e1ffe5d2f614201c11deed2703bd (diff)
gentoo auto-resync : 18:02:2023 - 02:09:39
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-9999.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 7ac6ddbd5d82..a5ba950fcf3f 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -2,4 +2,5 @@ DIST yt-dlp-2023.1.6.tar.gz 2529382 BLAKE2B d7682346f6a783e0e7b95fc312bb0fffc2b1
DIST yt-dlp-2023.2.17.tar.gz 2571278 BLAKE2B 74d077f5798e3371c42b5eb76e676619e7650a4003875d08995302c55120af7aa966a1e422cba6b0655cad4dedeed1874c2eb2348242fba9b0df12544d4dcfb3 SHA512 2458358410acb49ffc8fd4c49abddc78a5015ccf48979350fc5f9d4805c2dd8f7b728837ad30d55119cf8fc6842cba36a995ef9291da22af3135ae4a9077a5ba
EBUILD yt-dlp-2023.1.6.ebuild 1799 BLAKE2B c67eeebdc88c8f556892d11ac63be1e8a7c564749284d3e6797b78f8b6ddf709a6cf8f3a43b6a6a9ba501ff4f744afa6c20f683ddbe5d7214236d8939a4fc9bc SHA512 5e057ef308b4916e059ba20d708c6e3ab5742b2d96b20592d7092fe96249d5685ae8359706ea780537774933d3a2bc6a96bb5fbd852f3c8219de88979447c430
EBUILD yt-dlp-2023.2.17.ebuild 1799 BLAKE2B c67eeebdc88c8f556892d11ac63be1e8a7c564749284d3e6797b78f8b6ddf709a6cf8f3a43b6a6a9ba501ff4f744afa6c20f683ddbe5d7214236d8939a4fc9bc SHA512 5e057ef308b4916e059ba20d708c6e3ab5742b2d96b20592d7092fe96249d5685ae8359706ea780537774933d3a2bc6a96bb5fbd852f3c8219de88979447c430
+EBUILD yt-dlp-9999.ebuild 2032 BLAKE2B f621518216ab8ac6cac20a2083cce0f6f16133507fd09a2384d38504fa8bde43a7dc56903da889a87c477a4991204b266b02f5488ccc325819fde84c4a188ff6 SHA512 c623116051f3c327ebe130807b91aebf0de62f3593f70d41d7e2b7e4f60112223f8951645b860ce7817fe37acd0612c600a1020b1754cf7d15626927f65aa03f
MISC metadata.xml 505 BLAKE2B 520725078c47caf245904b10aab8929bf9a9a357a70315fda67e7dd59b77cb0c1614e7de03029772288aefa76678c7c4c97c7153364552f5ebe0f951df651e9f SHA512 af72cc5782fe5ed5a6748dcd7ebe7c9393ff7a9ad6d5a1a3a8c2824d323e86f1a97036745570790898fe9a51047601f9a4d95befc0e02b8c16822b7cc94e0734
diff --git a/net-misc/yt-dlp/yt-dlp-9999.ebuild b/net-misc/yt-dlp/yt-dlp-9999.ebuild
new file mode 100644
index 000000000000..ff0fc081c14a
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 distutils-r1 git-r3 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+EGIT_REPO_URI="https://github.com/yt-dlp/yt-dlp.git"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS=""
+IUSE="man"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]"
+BDEPEND="man? ( virtual/pandoc )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|websockets)/d" || die
+}
+
+python_compile() {
+ # generate missing files in live, not in compile_all nor prepare
+ # given need lazy before compile and it needs a usable ${PYTHON}
+ emake completions lazy-extractors $(usev man yt-dlp.1)
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ use man && doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}